4 Replies Latest reply on Oct 25, 2012 3:25 PM by The Almighty Egg

    RTMP Stream Not Found Error

    The Almighty Egg Level 1

      I am having difficulty with some RTMP streams and my OSMF implementation. I am attempting to play a series of RTMP streams, but for some reason, I cannot play them with OSMF (Stream not found). They play fine in JWPlayer, but I am unable to get them to play in Strobe or my OSMF Player. However, my OSMF player does play other streams. I cannot figure out what the difference is. Here is what I have:

       

      Demo streams:

      rtmp://cp67126.edgefcs.net/ondemand/mp4:mediapm/ovp/content/demo/video/elephants_dream/elephants_dream_768x428_24.0fps_408kbps.mp4
      rtmp://cp67126.edgefcs.net/ondemand/mediapm/strobe/content/test/SpaceAloneHD_sounas_640_500_short
      rtmp://cp67126.edgefcs.net/ondemand/mediapm/osmf/content/test/akamai_10_year_f8_512K
      
      

       

      Problem stream:

      rtmp://flash.delmar.cengage.com/DLvideo/00/03/32/33218.mp4
      

       

      OSMF and Strobe players CAN play the demo streams.

      OSMF and Strobe players CANNOT play the problem stream.

      JWPlayer CAN play the problem stream and the demo streams.

       

      I have tried setting the URLIncludeFMSApplicationInstance flag, I have tried removing the extension, and generally fiddling with the URL itself. I can change the protocol of the problem stream to 'http', and I get a progressive download which works in all players. Can anyone point me in a useful direction?