5 Replies Latest reply on Nov 1, 2012 12:45 AM by Acidic_Substance

    RTF files place very slowly

    Acidic_Substance Level 1

      Hi, I've been trying to work out this issue for a while now and no one has been able to help me. I need to place an RTF file that was specifically coded to have a set format. When the file is placed into PageMaker I have no problems with it. It places immediately and everything looks the way it should. But as soon as I try to place the exact same RTF into InDesign CS6 it hangs the program and takes forever to place. Copy/Pasting the text directly from the RTF (opened in Word) causes a loss of all the formatting, which I cannot lose. Is there some reason that the file refuses to place as quickly into InDesign as it does into PageMaker? Am I simply missing something or is there an issue with the updated software? The company I work for desperately wants to upgrade to InDesign but, as we are under very tight deadlines, we cannot move over until we resolve this issue.

        • 1. Re: RTF files place very slowly
          Peter Spier Most Valuable Participant (Moderator)

          Have you tried showing the import options when you place and selecting keep formatting?

          • 2. Re: RTF files place very slowly
            Acidic_Substance Level 1

            No, no, I think you misunderstand. When I place the file directly it retains all the formatting but it takes forever to place. We actually timed it here and when we placed the file into PageMaker it took 7 seconds but placing the exact same file into InDesign it took 12 mintues to place. I only mentioned the loss of formatting before because one suggestion I got to get passed the long placement time was to copy the text from Word and paste it into InDesign. But doing that erases all the formatting.

             

            The issue I have with placing the file directly (which is my only option as far as I can see) is purely time based. It just takes too long.

            • 3. Re: RTF files place very slowly
              Peter Spier Most Valuable Participant (Moderator)

              Try doing a Save AS in Word before placing (an make sure there are no outstanding tracked changes). RTF is usually reliable, but you might want to see if saving as .doc or .docx makes a difference.

               

              Also, check your application preferences under ClipBoard Handling. You should be able to set them to paste styles, not just plain text.

              • 4. Re: RTF files place very slowly
                Joel Cherney Adobe Community Professional & MVP

                Something is certainly odd about this behavior. Some additional questions for you, assuming a simple resave doesn't resolve your issue:

                 

                 

                What is in the RTF? Are we talking about a heavily-formatted two-hundred-page book with many tables, text boxes, embedded images, et cetera, or a two-pager with styled text only? Can you tell us more about how it was "specifically coded to have a set format?"

                 

                Speaking of which, how is the RTF being generated? Is it coming out of Word, or is something else generating it? InDesign has sometimes had a hard time with RTFs written by some kinds of applications, and I often have either Word or OpenOffice or LibreOffice or some other app capable of saving RTFs open to re-save crufty RTFs that come out of e.g. homebrew MySQL databases.

                 

                On what kind of computer(s) are you running  Pagemaker and InDesign CS6? I wonder what hardware you are using - maybe something radically under-specced for CS6? Also, what operating system is being used? These aren't both on the same machine, are they? Is there an OS that should work perfectly with both PageMaker from the 1990s and CS6 released around 15 years later?

                • 5. Re: RTF files place very slowly
                  Acidic_Substance Level 1

                  Wow, resaving seems to have fixed the problem. Hahaha I can't believe something so simple would make such a huge difference. Placing the file takes mere seconds now, lol. It certainly looks like the issue is solved but I'm going to have to check a few files before I'm 100% certain this is the best solution. Here's hoping XD Thanks Peter!