9 Replies Latest reply on Aug 18, 2017 1:41 AM by MaryAnnDesign

    Arabic full stop appears in front

    mmmsydney

      Hi I use CS InDesign 6. With world ready paragrapher composer, I can copy and paste Arabic text in CS6. But the full stop always appears in front of the last line. Not at the end. Any idea how to fix it?

       

      It's a pain to use a separate text box and put full stop in the right place manually.

        • 1. Re: Arabic full stop appears in front
          Ken G. Rice Adobe Employee

          Moved this post to the InDesign forum. They will be able to help you here.

          • 2. Re: Arabic full stop appears in front
            Joel Cherney Adobe Community Professional & MVP

            There are a variety of ways to make this work for you. I am assuming that you are using English-language ID and don't even know that there is an entirely separate Middle East Edition that gives you complete typographical control over right-to-left languages. The World-Ready Composer lets the letters of individual words compose correctly, but you need to turn on right-to-left paragraph direction - and there are no controls for same in non-ME editions of InDesign.

             

            So, unless you decide to go out and buy a whole separate license for the ME edition, your options are:

             

            1) Buy a plugin that exposes the RTL type controls. I always recommend World Tools from in-tools.com, because it exposes stuff in the ME edition as well as the CJK edition (Chinese, Japanese, Korean) in generic English InDesign. This is the best price-performance ratio, I think, for money spent to typographical control gained.

             

            2) Use a script or a template that already has those settings for right-to-left paragraph flow activated. If you search Google for "world-ready paragraph composer" you can find a few of those. I don't have a link on hand. They're out there, and they're free, but if you need to do something fancy (hanging indents, kashidas, LTR Arabic numerals for phone numbers and Hindi numerals for everything else, lots of bilingual sentences with frequent direction flow changes, and so on) you probably need either the ME edition or a plugin. You can do it with freely available character styles (or you can write 'em yourself if you know some Javascript) but I have found that to be a time-consuming way to work.

             

            3) But if all you need is one paragraph of legible Arabic... then you can start a new text frame, go to the Type menu, and hold down control and choose "Fill with Placeholder Text" and, instead of getting lorem ipsum, you'll get a dropdown menu that will let you pick fake text in a variety of scripts. If you pick Arabic, you'll get correctly flowing Arabic text with the right paragraph direction applied.

            • 3. Re: Arabic full stop appears in front
              mmmsydney Level 1

              Thank you Ken and Joel. I'm a member of the cloud. So I've uninstalled my English version and reinstalled the English - Arabic enabled version. It now works perfectly. I wished I had known about it in the last job!

              • 4. Re: Arabic full stop appears in front
                MaryAnnDesign

                Hi i have the same problem, how did you solve this?

                it's driving me crazy!!

                • 5. Re: Arabic full stop appears in front
                  MaryAnnDesign Level 1

                  Hi i have the same problem, how did you solve this?

                  it's driving me crazy!!

                   

                   

                  • 6. Re: Arabic full stop appears in front
                    Ericadyson Level 1

                    Are you sure you have right to left enabled in InDesign?

                    • 7. Re: Arabic full stop appears in front
                      MaryAnnDesign Level 1

                      I think so, but this is what i mean.

                       

                       

                      i am missing this:

                      • 8. Re: Arabic full stop appears in front
                        Willi Adelberger Most Valuable Participant

                        You don't show us anything.

                        Did you instal a MENA version? Change the preferences of the Creative Cloud settings to Arabic or Hebrew and install it again, no need to uninstall the previous version. Then you should have the functionality.

                        1 person found this helpful
                        • 9. Re: Arabic full stop appears in front
                          MaryAnnDesign Level 1

                          Yesssssss thanks a lot! it worked!