3 Replies Latest reply on Mar 5, 2008 6:51 PM by Aceinauck

    CSH not working

    Aceinauck
      Help me please! I have been pulling my hair out for almost two days now trying to resolve this. We have upgraded to RoboHelp HTML 7 and have had to convert some old .hlp help projects to a .chm. I imported these using RoboHelp - followed everything according to the book and successfully created the .chm help files. However the Map ID's do not work. The exe's are created in Visual FoxPro 8 and our developer has the right map ID's for the windows. I have checked that these ID's are correctly mapped to the topics and have use the CSH test tool and they work fine using this. However it refuses to work when called up from the application. It loads the help - but to the default topic only. Stangely we did another conversion using RoboHelp for word (same version) and this worked? Why would one work and not the other? On this topic my RoboHelp for word (office 2007) has just stopped working!! I can create a project - but when I try and compile - nothing happens?
        • 1. Re: CSH not working
          Pete Lees Level 2
          Hi, and welcome,

          Is the developer shipping all the files required to call HTML Help files from a FoxPro application? With FoxPro 7.0 at least, two additional files are required in order for HTML Help files to work properly: FoxHHelp7.exe and FoxHHelpPS7.dll. Maybe version 8.0 is the same.

          Here's a Microsoft Knowledge Base article on the problem:

          "PRB: HTML Help Does Not Work from VFP Application"
          http://support.microsoft.com/?kbid=314296

          Some additional resources on using HTML Help with FoxPro applications are listed at the end of the following page:

          http://www.mshelpwiki.com/wiki/tiki-index.php?page=HTMLHelpArticles

          Pete
          • 2. Re: CSH not working
            Aceinauck Level 1
            Hi Pete, thanks for the reply.

            Yes, both FoxHHelp8.exe and FoxHHelpPS8.dll have been registered
            .
            Although those links were useful, they still did not provide a solution to my problem. I have also tried Adobe support and 3 days have passed without an answer - I have to admit - it's a tough one.

            I seem to have a knack for attracting these bizarre problems, anyway this one has become just a little more than a nuisance - we are have to publish the help in a few days and the F1 functionality is still not working. I find it hard to believe that no one else has suffered a similar problem to ours. Any suggestions would be greatly welcomed.
            • 3. Re: CSH not working
              Aceinauck Level 1
              Hi - Thanks again to Pete for trying to help. I eventually managed to resolve this problem myself. The application was calling up ID's from separate modules. Each of these modules had a separate help and I think the Map Id's where somehow conflicting. I've concluded that it's on the application end and nothing to do with RoboHelp, phew.

              It still has not been completely resolved, however I have managed to get to the root of the problem and have ruled RoboHelp out as being the culprit.