2 Replies Latest reply on Oct 31, 2012 12:32 AM by pwillener

    plz help i really need help

    wally239

      i downloaded the lates adobe flash player but when i get on the internet to watch a video it tells me i need the lates adobe flash player. it dosent let me watch the video. why is this happening how can i fix it????