2 Replies Latest reply on Nov 2, 2012 12:58 PM by Jim_Simon

    Premiere Pro CS6 Constantly Crashes/No Video Visible but Audio works (DisplaySurface.dll) -HELP!-

    +Suzerain+

      Just a couple of days ago, I started getting constant crashes in Adobe Premiere Pro CS6. When I checked Event Viewer, it keeps saying the fault module is 'DisplaySurface.dll'. I tried searching online but that didn't give any useful resources so I figured I'd ask here.

       

      This is the error dialog in Event Viewer:

       

      Faulting application name: Adobe Premiere Pro.exe, version: 6.0.3.0, time stamp: 0x505748bf

      Faulting module name: DisplaySurface.dll, version: 6.0.3.0, time stamp: 0x5057418f

      Exception code: 0xc0000005

      Fault offset: 0x0000000000020b91

      Faulting process id: 0x1504

      Faulting application start time: 0x01cdb9276387123a

      Faulting application path: F:\Adobe\Adobe CS6 Master Collection\Adobe Premiere Pro CS6\Adobe Premiere Pro.exe

      Faulting module path: F:\Adobe\Adobe CS6 Master Collection\Adobe Premiere Pro CS6\DisplaySurface.dll

      Report Id: ac76d5db-251a-11e2-a5af-bc5ff4557110

       

      I am running a triple-monitor setup with NVidia Surround and have several GTX-680s in SLI. I have 32GB RAM and a 3930K CPU. The computer is otherwise rock-solid and Premier Pro CS6 has worked fine all this time until about two days ago. I did install some trial version of NewBlueFX but I don't think that could be causing this since the fault module is 'DisplaySurface.dll'(?).

       

      I tried opening several different projects and the same error/crash occurs. I am able to import videos into the time line. However, there is no video visible in the preview window (nor the Source window). The Audio works fine. Sometimes, when I open a project with videos already in the timeline, CS6 just crashes with the same error. I have set the memory level to 27GB across all Adobe apps and am using "Memory" setting for rendering along with "Maximum Bit Depth" and "Highest Quality"(?). I tried changing the setting to "Performance" but that still gives me the same error/crashes.

       

      Please help as I need to get this reesolved ASAP for my work.

       

      Thank you.