6 Replies Latest reply on Feb 13, 2013 2:58 PM by robogirl62

    Failed to Load XML File

    jclguru Level 1

      Using RH 9.

       

      When trying to search for EMC, the result is 'failed to load xml file'. I've tried searching

      for other 3 letter words and fewer and have received results. I've also tried searching for

      other words in the same sentences that emc is located and have returned with results.

       

      Just getting that error for that one word.

       

      I saw one other person had this error, I think back in January, but he never followed up

      on any possible resolution.

       

      Ideas?

       

      Thanks

        Doug

        • 1. Re: Failed to Load XML File
          RoboColum(n) Level 5

          Can you tell us what your output is?

          • 2. Re: Failed to Load XML File
            jclguru Level 1

            I'm using WebHelp if that's what you mean? Been using that for the past couple of years.

             

            Doug

            • 3. Re: Failed to Load XML File
              Willam van Weelden Adobe Community Professional & MVP

              Hi,

               

              I hope Colum doesn't mind me budging in. This error normally indicates that the WebHelp scripts could not load the XML resource files located in the folder whxdata. Can you check the following:

               

              1. Clear your entire !SSL! folder by hand to make sure it's empty.
              2. Generate your help.
              3. Check that the folder whxdata contains files called 'package_<number>.xml'.

               

              Do you see any of these files? If so, check the search function. Is it working OK?

               

              Are you using merged help or just a single project?

               

              Greet,

               

              Willam

              • 4. Re: Failed to Load XML File
                RoboColum(n) Level 5

                Is this issue being seen on both the generated and published output? If not, how is the help being opened (i.e. manually via a shortcut, via a CSH call, elsewhere in a product).

                • 5. Re: Failed to Load XML File
                  RoboColum(n) Level 5

                  Be my guest Willam. I tug my forelock in your direction

                  • 6. Re: Failed to Load XML File
                    robogirl62 Level 1

                    Was there ever a final resolution to this thread? I am seeing this same issue in a merged WebHelp file that I have. I am using RoboHelp version 8.02. Some searches work fine and generate results; others generate the Failed to load xml file error. Doesn't seem to be a clear rhyme or reason, although I did get the error when searching on keywords starting with a W (referring to the other thread on this issue).

                     

                    I tried clearing the !SSL! folder for each of the projects and re-generated each individual help file. Still get the error. The whxdata folders in each output do contain the package files - some have only one (package_0.xml) while others have multiple package files. Anyone know what determines how many of these package files get generated?

                     

                    Happy to send screen shots if it will help troubleshoot, or is this an issue to take up with Adobe support?

                     

                    Thanks in advance for any assistance!