2 Replies Latest reply on Nov 8, 2012 9:16 AM by Andy W 123

    flexunit4 in FB standard says 'BUY PREMIUM' when I debug run in a test, but not elsewhere  :-(

    Andy W 123

      I have FlashBuilder 4.6 standard and have successfully set up flexunit in a project with several tests. When I run debug whilst viewing a test, I get the popup message saying 'buy premium...'.  This does not happen when viewing other classes.  Fairly frustrating having to navigate to another class each time I want to test a test I am writing.  Can you suggest a work around?

      Thanks,
      Andy.

        • 1. Re: flexunit4 in FB standard says 'BUY PREMIUM' when I debug run in a test, but not elsewhere  :-(
          mlabriola Level 4

          Andy,

           

          Just a quick note, FlexUnit is an open source unit testing framework. There is no cost, etc. to use it. Flash Builder offers a wizard to make unit tests and a little panel to show your test results. That is the premium feature. So, unfortunately, the issue you are seeing belongs to Flash Builder, not to FlexUnit.

           

          That said, you dont need to use that panel if you do not want to. You could setup FlexUnit as per the FlexUnit wiki or tutorials. This would mean you wouldnt get your results in the FlexUnit panel in Flash Builder, but you also wouldnt be bothered by their inability to test their code.

           

          Mike

          • 2. Re: flexunit4 in FB standard says 'BUY PREMIUM' when I debug run in a test, but not elsewhere  :-(
            Andy W 123 Level 1

            Hi Mike. Thanks for the prompt response.

            So what is happening then is that flashbuilder tries to run premium

            features when i debug whilst viewing and editing a test. But, is there no

            way i can just disable it trying to run this premium feature?  I guess this

            premium feature may 'fire' due to your special meta tags in test classes? I

            currently get the results of the tests in a similar fashion to trace

            statements.

            Could well be i've set up my usage of flexunit weirdly. Hate to bother you,

            but could you give me a url to a tutorial on setting up flexunit on fb

            standard for actionscript only projects? I couldnt really find a good

            overview and ended up looking at overviews for flex projects and then

            fiddling until i got it working for my scenario.

            Thanks so much

            Andy