0 Replies Latest reply on Mar 6, 2008 7:17 AM by tjfeuling

    Problems recording with QTP

    tjfeuling
      So I have a Flex 3 Professional install as well as a Mercury QTP 9.2 install. I have gotten it so Mercury can record the events from the sample flex application provided by Adobe (the phone store); however, I am unable to record events from a test application I have created. I have tried both loading the automation framework at run-time. Loading the runtime page for my application just show the normal flex app background and then causes IE to hang. I have also tried loading the libraries statically. I am using

      -include-libraries
      "C:\Program Files\Adobe\Flex Builder 3\sdks\3.0.0\frameworks\libs\automation.swc"
      "C:\Program Files\Adobe\Flex Builder 3\sdks\3.0.0\frameworks\libs\automation_agent.swc"
      "C:\Program Files\Adobe\Flex Builder 3\sdks\3.0.0\frameworks\libs\qtp.swc"
      "C:\Program Files\Adobe\Flex Builder 3\sdks\3.0.0\frameworks\libs\automation_dmv.swc"

      as my arguments in the flex "Additional compiler arguments" as well.

      I have been deploying it a simple web server as well as referencing the wrapper which was made by Flex Builder 3 instead of the swf. Is there something I am missing to get automation testing working? Any help would be greatly appreciated.