3 Replies Latest reply on Nov 14, 2012 11:06 AM by Peter Grainge

    Font Changes After WebHelp is Generated in RH10

    Cdodik

      I'm having an isssue that is similar to this topic: http://forums.adobe.com/message/4751049 However, my issue is with RoboHelp HTML, not RoboHelp for Word.

       

      We recently downloaded the trial version of RoboHelp 10 to determine if our help files, which were created in RoboHelp 2000 (possibly, that was before my time, and that is the latest version I was able to identify on a CD here) could be updated. Everything works great, except that when I generate WebHelp or HTML Help, some topics appear in Times New Roman. Based on the applied CSS file and the way that the project looks in RoboHelp, everything should be in Arial.

       

      I have re-applied the CSS file to all topics, checked to make sure the appropriate style was being applied to the text in the topics that were showing up incorrectly, and tried applying the default and other CSS files.

       

      I'm using Windows 7 and Internet Explorer 9 to view the WebHelp.

        • 1. Re: Font Changes After WebHelp is Generated in RH10
          Amebr Level 4

          There was a pretty significant paradigm shift starting with RH7 to move to standard HTML and CSS support. This resulted in significant changes to styles and also how you select the styles to apply to paragraphs.

           

          For example, in RH6 the H1 style was defined twice like so:

          H1 {

          font-family: Arial, Helvetica, sans-serif;

          }

           

          LI.kadov-H1 {

          font-family: Arial, Helvetica, sans-serif;

          }

          RH7  changed like so:

          H1 {

          font-family: Arial, Helvetica, sans-serif;

          }

           

          LI.H1 {

          font-family: Arial, Helvetica, sans-serif;

          }

          Possibly the  kadov- part hasn't been removed from the stylesheet. Or perhaps it has been removed from the stylesheet, but not from the topics.

           

          There is also a topic on Peter Grainge's site (www.grainge.org) that discusses Lists, as these caused a lot of problems on upgrade, so you could read through that for more information as well. I'm unsure if you are familiar with Robohelp, but thought I'd point out that unlike Word, the Style drop-down in the toolbar only displays paragraph and character styles - to see all possible styles (like list styles) you need to use the Style Pod (unless this has changed recently - I have up to RH8 available to me).

           

          Another option is to create a brand new stylesheet so you can compare the imported stylesheet with the native RH10 stylesheet - be wary of implementing all the differences though, as some of your choices will depend on the HTML code in the topics as well.

           

          Hopefully some of this will help you with your issue though,

          Amber

          • 2. Re: Font Changes After WebHelp is Generated in RH10
            Cdodik Level 1

            Thank you, Amebr! The topic on Peter Grainge's site provided the answer.

             

            For anyone reading this who is encountering this issue, go to Tools > Options and select "Convert RoboHelp-edited topics to HTML".

            • 3. Re: Font Changes After WebHelp is Generated in RH10
              Peter Grainge Adobe Community Professional (Moderator)

              The fact that fixed your problem suggests something in your project is not XHTML compliant. I would start by checking the CSS file, then it is a matter of working through the HTML topics. It may be you don't have the level of knowledge of HTML to clean things up. In that case just make sure your output created using this solution works without issue.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

               

              @petergrainge