7 Replies Latest reply: Jul 30, 2014 9:47 PM by Brad Grigor RSS

    Can't install Adobe Digital Editions 2.0 on Windows 8

    Alcenana Community Member

      The ADE2.0 installer asks for Microsoft .NET Framework 3.5 Service Pack 1 on my fresh install of Windows 8 (over Vista), but I'm up to date with everything in Windows Update.

       

      I tried downloading and installing .NET from the page suggested by the ADE intaller but when I launch the .NET installer it says I already got that or a newer version.

       

      On the Adobe site I can't find anymore the ADE 1.7.2 installer.

       

      Is it a known issue or is it just me?