14 Replies Latest reply: Nov 2, 2014 10:19 AM by Jack Banatoni RSS

    Adjustment Layer Oddities

    J. Simon Community Member

      I'm seeing some new and unwanted behavior using Adjustment Layers.  I love to use these for grading, CC and other effects, as I can easily apply one setting to a whole range of clips.  However, sometimes a clip will require tweaking of those settings, or an additional effect.  So I cut the AL to match the clip, then apply dissolves on the AL to match the dissolve on the clip.  Below is a screen shot.

       

      Adjustment Layers.png

       

      The problem is that the footage has started to freeze during the transitions, as if a frame hold is in effect.  Normal playback resumes after the transition.  That freeze also causes the export to fail with an Unknown Error.  If I remove the dissolves from the AL, all works fine, except that now the different settings on the AL effects just 'cut', which is jarring and unwanted.  It happens across media types and export settings, but strangely only on one of my two computers. Unfortunately it's my production rig, my personal computer still works fine with this.  (Damn, why couldn't that be reversed!)

       

      Is anyone else seeing any issues with dissolves applied to Adjustment Layers?

        • 1. Re: Adjustment Layer Oddities
          J. Simon Community Member

          Has anyone else even tried using transitions on an AL?

          • 2. Re: Adjustment Layer Oddities
            needles27 Community Member

            Jim,

             

            Just tried it on some test clips - same result as yours.  I tried it with 1 adjustment layer razored, and again with 2 different adjustment layers. Both had a freeze-frame during the transition and then picked up again after the transition end.  Looks like you found a bug.

             

            I'm on a MacPro 4,1

            10.8.2

            CS 6.0.2

            • 3. Re: Adjustment Layer Oddities
              J. Simon Community Member

              Interesting.  Thanks for checking.

               

              It used to work, though.  And still does on my Windows 8 machine.  Just not on my primary Windows 7 edit machine.

               

              One other oddity I noticed is that if I turn off CUDA acceleration, it just goes black instead of freezing.

               

              Anyone else ever try this?

              • 4. Re: Adjustment Layer Oddities
                Greg Baber Adobe Employee

                Hi Jim,

                 

                I just tried to recreate on my MBPRetina.  It actually transitioned nicely for me - never would have thought of it but it's a cool effect.  

                 

                Let's double check the version and the video hardware to see if that's something you have in common with needles27 but not with me.

                • 5. Re: Adjustment Layer Oddities
                  Steven L. Gotz Community Member

                  I didn't understand the point of the transition on the AL at first. I had to dissolve between two radically different images to get what you meant.

                   

                  While trying this out, I put a cross dissolve between a couple of clips, put an Al over them and used the Fast Color Corrector on the AL. So far so good. I then cut the AL and made changes to the color correction on the first half of the AL. I then put a Film Dissolve on the cut on the AL. I think that is what you used.

                   

                  Much to my surprise, when I tried to change the colors on the second half of the AL, I couldn't. The wheel changed but had no effect on the video. Very odd. I deleted the transition. Same problem. I copied everything on the timeline over to a new sequence and it behaved normally. Very odd. Works fine now.

                   

                  I have not been able to duplicate the problem. And the transition between the two parts of the AL really helps. I am sorry you are having troubles but it turned out to be a nice tip for me.

                  • 6. Re: Adjustment Layer Oddities
                    J. Simon Community Member

                    I'm using a 560 Ti on the machine that works, and a 470 on the one that doesn't.  Both are using the 306.97 driver.  PP 6.0.3 on both.

                     

                    Needles?

                    • 7. Re: Adjustment Layer Oddities
                      J. Simon Community Member

                      Anyone else give this a try?

                      • 8. Re: Adjustment Layer Oddities
                        needles27 Community Member

                        I have the GTX 285 with GPU Driver Version: 1.3.4.0 (304.00.05f02) on a MacPro 4,1 10.8.2 with CS 6.02 (Latest for Mac)

                        • 9. Re: Adjustment Layer Oddities
                          tatoz

                          Here, 6.03 without cuda, black screen. But, if I add a Crop effect (or an Brightness&Contrast, or certain effects without changing the parameters), works well. And, if I put the opacity to %99.99, works too (and the opacity is listed as %100). Another strange thing is if you add a fade-in to an Adjustament Layer, this fade from black (or maybe frezee frame in your system?), and not from transparency (you have to animate by keyframes the opacity to do this...). Sorry for my bad inglés.

                          • 10. Re: Adjustment Layer Oddities
                            J. Simon Community Member

                            In my brief initial test, adding an unmodified effect does indeed cause things to work normally.  That's not something I'd have though of.  Thanks for the tip, tatoz.

                            • 11. Re: Adjustment Layer Oddities
                              alanst2 Community Member

                              Was this ever worked around? There do not seem to be any entries since 2012.

                               

                              I have just come across the same problem. I created a sequence in Windows 8 and later wanted to on it on it in W7 Home Premium. At the beginning of the Adjustment layer I placed a cross dissolve, in order to fade up a group of video tracks simultaneously. But each time I loaded the sequence, the machine stopped responding to transport, or any, keyboard commands. After much head-scratching and cursing, I began to remove FX and video tracks from the work until it began working again. In my case it would load as expected but from then on no amount of cajoling would make anything keyboard connected work. Using the mouse gave some control, i.e. selecting panels, but it appeared that the 'monitors' were in an odd state,leaving tails of everything that passed over them, whether part of Premiere or not.

                               

                              I tried using key-frames on the Adjustment Layer, to change the opacity (noting that somebody suggested 99.9% instead of 100%) but that didn't appear to work at all.

                               

                              Did anyone sort this? If so, how.

                               

                              Many thanks.

                               

                              AlanS.

                              • 12. Re: Adjustment Layer Oddities
                                Steven L. Gotz Community Member

                                To fade up a bunch of tracks all at one time, rather than use an adjustment layer, simply use a piece of black video and fade it to zero opacity over time.

                                 

                                I haven't seen the problem, but then again, every project I have created for many years has had a sequence with misc items like a black slug with a fade out. Nowadays, I can adjust a clip in the Project Panel, but I still just import that same old sequence with lots of useful stuff on it.

                                • 13. Re: Adjustment Layer Oddities
                                  alanst2 Community Member

                                  Thanks for the reply, Steven. That's an obvious way, when it occurs to me!

                                   

                                  I suppose with so many moving to W8+ it is no longer a prority.

                                   

                                  Thanks again,

                                   

                                  Alan S.

                                  • 14. Re: Adjustment Layer Oddities
                                    Jack Banatoni Community Member

                                    Just ran into this on Premiere Pro CC.  Adding a default Fast Blur effect (set to 0) on the adjustment layers seems to work around the issue.