1 Reply Latest reply on Nov 20, 2012 10:22 PM by raZorTTZ

    CFBuilder, CF10 (multihoming) and admin services

    raZorTTZ

      Hi folks,

       

      I am setting up a development server with 2 instances of coldfusion running (cfusion + instance0)

       

      I was wondering if anyone has been able to get the admin services working when cf instances are set up in a multihoming arrangement?

       

      I have looked through the CFBuilder documentation and it seems to be skewed towards CF9 and Jrun. I am able to add the servers in CFBuilder and have it correctly report the current status, but if I try to stop, start or restart a server from CFBuilder nothing happens.

       

      I initially tried to get it working with just the default cfusion instance and when I tried to stop, start or restart I would get an error in the cfbuilder server console


      Error(11/21 at 03:06:01) Cannot perform the operation. Admin server for the remote server 192.168.0.10 is not running.

       

      After looking around the web (I can't remember who posted the info, but thanks!) I found that I needed to comment out the host node in the {CFHome}/cfusion/jetty/etc/jetty.xml file.

       

      <Call name="addConnector">

            <Arg>

                <New class="org.mortbay.jetty.bio.SocketConnector">

                  <!-- <Set name="Host">127.0.0.1</Set> -->

                  <Set name="port"><SystemProperty name="jetty.port" default="8985"/></Set>

                  <Set name="maxIdleTime">50000</Set>

                  <Set name="lowResourceMaxIdleTime">1500</Set>

                </New>

            </Arg>

          </Call>

       

      After that I created a second ColdFusion instance and then added it to the servers view in CFBuilder neither of my servers can be stopped, started or restarted via the IDE.

       

      Does anyone have any suggestions?

       

      Thanks,

      Simon

        • 1. Re: CFBuilder, CF10 (multihoming) and admin services
          raZorTTZ Level 1

          How can I confirm that the admin service have been installed? Is there a file I can check for or something in an xml file somewhere? I have another server that I'd like to try, but can't remember if I said yes to the admin services.

           

          If you see

           

          #Remote Component Administrator Credentials

          #------------------------------------------

          JETTY_USERNAME=

          JETTY_PASSWORD=

          JETTY_PASSWORD_CONFIRM=

           

          in the log does that mean it should be installed?

           

          Cheers,
          Simon