12 Replies Latest reply on Nov 26, 2012 8:34 AM by frogo369

    Problem setting up RAID0 on ASUS p9x79Pro

    Stu S Level 1

      I’m having problems setting up a RAID0 on my new p9x79pro build, and I think I’m following the right procedure, first time doing this and it’s not working, so I could really use some help.

       

      I pre-installed the Intel drivers downloaded from ASUS prior to installing Windows 7 using the f6 method.

       

      After installing, I ran the Intel rapid storage enterprise installer software, and the raid controller shows up in Device Manager.

       

      I then followed the procedure in my mobo manual.  I went into the bios, into advanced mode, changed my drives from ACHI to RAID mode, and then went into Ctrl I mode and tried to set up a raid.  The two new WD 1 TB black caviars I have were visible, but greyed out and described as “non-raid disks”.  When I went through the process, they remained greyed out, and I could not select any drives to raid, though I tried creating a RAID0 anyway.

       

      These drives, both new, had already been partitioned.  These drives are plugged into the top two sata 6gb ports on the mobo, which should be correct according to the manual. 

       

      When I rebooted, my drives were not visible, and as expected, there was no RAID0.  I went back into BIOS, deleted the (nonexistent) raid, and reset the drives to ACHI, but the drives still did not show up.

       

      So, thinking I screwed up somehow, I did a full reinstall of windows.  After installing the Intel enterprise installer software, I went into device manager and the drives were back, but unpartioned.  Before partitioning, I tried to RAID0  these again, using the above method, but no luck, still greyed out.  I also made sure to let windows connect online to download any hotfixes, which it did.  All my other drivers are up to date, as is BIOS.  Before I partition these drives and try again, figured I’d ask here. 

       

      I think I’d be there, if only the drives were not greyed out.  What am I doing wrong?

       

      Also, if I were plugged into the bottom two drives (the Marvell controller, which show up in Device Manger, so it appears to have installed) how would I set up a RAID0?

       

        Thanks

        • 1. Re: Problem setting up RAID0 on ASUS p9x79Pro
          Bill Gehrke Adobe Community Professional & MVP

          I just reinstalled my RAID 0 on the Marvell 6 Gb/s ports on my Gigabyte board but if you have the current Marvell drivers installed you should be able to reboot go to the BIOS and set it for RAID and then reboot again do a Ctrl-M and install the two drives as RAID 0, and after another reboot it should be installed.  Fantastic results!

          • 2. Re: Problem setting up RAID0 on ASUS p9x79Pro
            Cocovanna Level 1

            I used the Intel 6GB ports for my SSD boot disk and an ordinary disk. The bext two 3GB ports was used for BD drive and anoher disk. The last two Intel 3GB ports was used for a Raid 0 with the last to disks.

             

            I believe you SHOULD use one of the two first (or better, the first) for the boot disk, although th system starts anyway. Maybe it can be why you can't use them.

             

            You don't loose performance by using the 3GB ports for the Raid

            • 3. Re: Problem setting up RAID0 on ASUS p9x79Pro
              Stu S Level 1

              Should the drives be formatted before RAIDing?

              • 4. Re: Problem setting up RAID0 on ASUS p9x79Pro
                frogo369

                When using Raid you want to ensure you install with RAID already set within the UEFI. While you can change after the fact depending on multiple aspects this can cause issues.

                 

                Additionally prior to beging the steps below i would ensure the items below.

                1. Update your SSDs to the latest firmware.

                2. Secure Erase your SSDs using their utility or general purpose application like Parted Magic.

                3. Ensure you are using the correct controllers

                The boards has 6 ports provided by the PCH 2 SATA6G and 43G. There is additionally a Marvell controller that offers SSD Caching ideally i would only advise raid be used for this drive with mechnial volumes not SSD volumes. It's primary inclusion is for AHCI single drive expansion or SSD Caching ( SSD + Mechnical HD ).

                 

                * One last note is be careful creating raids between UEFI Updates. Some UEFI updates can contain OROMs ( option roms ) which control the functionality of the Raid functions of the PCH. If different OROMs are utitlized to create or delete raids it can cause problems.


                Steps to follow.

                 

                1. Default UEFI

                2. Set SATA configuration mode to RAID

                3. Define Raid within the RAID managment console ( Ctrl I )

                4. Attached any other driver being used ( they will work in AHCI if single drives )

                5. Proceed to complete normal installation  F6 drivers are only required if you want advanced level functionality and rebuild options from Intel RST software.

                 

                Hope this helps.

                 

                Enjoy the rest of your day!

                • 5. Re: Problem setting up RAID0 on ASUS p9x79Pro
                  Stu S Level 1

                  Thanks frogo369.  These are not SSD's they are 1TB WD 64mb cache sata 6 mechanical drives.  I'm going to try switching to the 3gb intel ports and see if that helps.  If not, I'll try the bottom two Marvell ports, but I would like to get the intel ports to work, so if anyone else has any other ideas, much appreciated.

                  • 6. Re: Problem setting up RAID0 on ASUS p9x79Pro
                    Stu S Level 1

                    Tried Cocovanna's configuration using the 3gb ports and it worked fine.  Tried building a RAID0 on the Marvell ports and it works fine. 

                     

                    Bottom line, though it appears nowhere in any documentation I could find, you cannot create a RAID using the top two 6gb intel ports on this Mobo.  Only the four 3gb Intel ports work for RAID0.  If anyone cares to confirm this, jump in.

                     

                    The bottom two Marvell 6gb ports work for RAID, and for now, that's what I'll use.  Probably compare speed later on.  Wasted a good chunk of time on this today, but take some small comfort in the fact that it wasn't my bad.

                    • 7. Re: Problem setting up RAID0 on ASUS p9x79Pro
                      frogo369 Level 1

                      Something is off as the Intel SATA6G ports fully support raid. I would consider doing a write zeros on your drives and and retry creating on the Intel ports.

                       

                      I complete a quick check on a P9X79 Pro without issues screen below for your reference.

                       

                      Steps used ( already had OS install on single SSD ). Completed using UEFI defaults ( drive was installed under AHCI ).

                       

                      Step 1. Connected 2 SSDs to the Intel SATA6G ports white ports not label SSD Caching ( which are the Marvell ports )

                      Step 2. Entered into the UEFI and changed to Raid

                      Step 3. Saved and reboot and entered into Raid Console ( Ctrl I ), Once enter created Raid 0 and defined 2 Corsair drives as drives to be used in Raid

                      Step 4. Rebooted and entered OS and install RST driver/application.

                       

                      Included some screenshots including performance throughput of 2 SSDs on SATA6G ports which can only be achevied via Raid0 on Intel SATA6G ports.

                       

                      121121192943.jpg

                      121121192956.jpg

                      Port Check Intel SATA6G 1.jpg

                      Port Check Intel SATA6G 2.jpg

                      SATA6G Raid0 Working.jpg

                       

                      One thing that was not clear is where is your OS present / installed and on which port?

                       

                      Hopefully you will be able to get this sorted and resolved. Then again if you are ok running the Raid on the Marvell ports you are already solid.

                       

                      Enjoy the rest of your day.

                      • 8. Re: Problem setting up RAID0 on ASUS p9x79Pro
                        Cocovanna Level 1

                        Bill, the Marvell controller at the Asus board is 9128. I don't which Gigabyte you have, but I think it might be the newer (and better) controller -- I would stick to the 3G ports for Raid 0 with the Asus (but I haven't tested it, just base it on tons on information I've digested on the net ...)

                        • 9. Re: Problem setting up RAID0 on ASUS p9x79Pro
                          Bill Gehrke Adobe Community Professional & MVP

                          Cocovanna, I have to agree with you now that I have tested the Marvell 88SE9172 6Gb/s with two Seagate 6Gb/s 2 TB 7200.14 drives against the same two drives on the Intel 3Gb/s ports.  The overall performance is close (average read transfer rate) is 307 MB/s to 314 MB/s, but (my theory) the starting point of my HD Tune Pro testing is not quite as fast as on the Marvell controller because it is limited by the PCIe x1 connectionthis causes a flat initial 40% of the drive. Next step after todays Turkey is to run the same drives on the two Intel 6 Gb/s ports.

                          • 10. Re: Problem setting up RAID0 on ASUS p9x79Pro
                            Stu S Level 1

                            Frogo thanks very much.  My OS, also on a new WD 1tb 64 mb SATA, was on the bottom sata 6 bottom port at the time.  I'm going to try moving it to another port and giving it another try.  I can use the 3g ports, but I'd like to figure this out on principal.

                            • 11. Re: Problem setting up RAID0 on ASUS p9x79Pro
                              Stu S Level 1

                              frogo369, writing zeros to the disks did the trick, I can now create a raid on any port.  Weird, but I'll take it, thanks.

                              • 12. Re: Problem setting up RAID0 on ASUS p9x79Pro
                                frogo369 Level 1

                                No problem glad it worked out. The writing zeros or secure erase is always a precaution I recommend especially if the drive has been used and even more so previously with RAID or on different controllers.  Interesting things happen to the drives at times depending on OROM differences, formatting, partitions and more.

                                 

                                Regardless glad it is working! Enjoy the rest of your day.!