2 Replies Latest reply on Nov 22, 2012 9:23 AM by Softterrier

    Solving important deficits: Spry to jQuery and PhoneGap Plugin support

    Softterrier

      Hallo,

       

      I have two short questions to the next Dreamweaver upgrade:

      1.) when will Spry be exchanged with jquery? (it does not make sense that there is used jQuery Mobile on one side but Spry (instead of jQuery) on the other)

      1b.) Which disadvantages does it have that there is a mixture of frameworks here (besides the fact that I have to learn two frameworks)?

      1c.) Will my current (Spry) code be compatible on an upgrade DW version with jQuery support? (I suppose Yes, as long as I use the Spry function objects, right?)

       

      2.) Why does DW CS6 not support PhoneGap plugins? Consequences?

      2b.) Why does that mean that I cannot import or use foreign code (e.g. WebApp code developed with Eclipse)?

      Remark: I have read that I e.g. cannot translate PhoneGap locally to link several foreign libraries, etc.

       

      3.) Are you currently working at these IMPORTANT issues? When about can we expect a DW version (CS 6.5?) with at least these two improvements?...

      3b.) Which important issues do you presently work on as well?

       

      Thank you very much.

        • 1. Re: Solving important deficits: Spry to jQuery and PhoneGap Plugin support
          BenPleysier Adobe Community Professional & MVP

          1.) when will Spry be exchanged with jquery? (it does not make sense that there is used jQuery Mobile on one side but Spry (instead of jQuery) on the other)

          You can bet your bottom dollar that, with the demise of Spry, it will not be included in DW CS7

          1b.) Which disadvantages does it have that there is a mixture of frameworks here (besides the fact that I have to learn two frameworks)?

          Used with care, the two frameworks work fine together. Problem is the overbloated coding.

          1c.) Will my current (Spry) code be compatible on an upgrade DW version with jQuery support? (I suppose Yes, as long as I use the Spry function objects, right?)

          Correct. Most likely you will not be able to use Spry as you have been used to, I think that Spry will need to be hand coded.

          2.) Why does DW CS6 not support PhoneGap plugins? Consequences?

          Have a look here http://phonegap.com/2012/04/24/adobe-dreamweaver-cs6-supports-phonegap-build/

          2b.) Why does that mean that I cannot import or use foreign code (e.g. WebApp code developed with Eclipse)?

          Remark: I have read that I e.g. cannot translate PhoneGap locally to link several foreign libraries, etc.

          See above

          3.) Are you currently working at these IMPORTANT issues? When about can we expect a DW version (CS 6.5?) with at least these two improvements?...

          3b.) Which important issues do you presently work on as well?

          You (Softterrier) are placing your questions in a user to user forum. We can only pass on our impressions.

          • 2. Re: Solving important deficits: Spry to jQuery and PhoneGap Plugin support
            Softterrier Level 1

            Hallo,

             

            hmmh, I was told by the Adobe hotline that this forum would be monitored and reported also by Adobe developers.

            This would be the way to reach Aobe development.

            So if not do you know which forum to use for that?...

             

            Why do you think that Adobe will exchange jQuery with Spry not even in version 7 ?

            Actually I have read in a book that they shall work at this issue already.

             

            To your link... do you mean this?... "we're working with Cordova to create a standardized method of writing plugins. Currently, plugins are added to build manually as each plugin..."

             

            Does not help so much... Why can I develope an app with linked libraries in Eclipse but not so at Dreamweaver?

            I have heard that Phonegap would support plugins when built locally. Is that correct?

            So with Dreamweaver I cannot build an app locally with Phonegap, right?

            Why is that so difficult in Dreamweaver CS6 now?... Why is an extra Phonegap plugin API necessary?

            Why Eclipse does not need it !!!!

             

            Sorry, I don't understand this technically.