5 Replies Latest reply on Nov 28, 2012 1:02 PM by Todd_Kopriva


    Panthers Edit

      So I have a new PC WINDOWS 7 64-bit DELL Precision T7600

      64 GB of RAM- and when I render it typically tells me it is only using 8 - 11% of the RAM




      I thought I had my prefernces set up correctly - any insight and tricks into using ALL of my RAM would be awesome.

      This box typically only renders AE files... and I'm afreaid I am not getting my 64GB worth



        • 1. Re: MAXIMIZING my RAM
          Mylenium Most Valuable Participant

          Long and short answer: You are using a temporal effect or feature that causes AE to revert to single process rendering. Refer to this:


          After Effects Help | Memory and storage


          Beyond that there is no way to enforce more memory usage or better CPU usage. AE takes what it needs given on a specific situation and that is that. also search the forum for past discussions on "ideal multiprocessing settings" or "optimum PC".



          • 2. Re: MAXIMIZING my RAM
            Panthers Edit Level 1

            The temporal effect reason makes a lot of sense- it took a little more work to find a simpler explanation for me to understand.

            Considering the effects I am rendering with- that seemed like a good explanation.


            Searching the forum for  "ideal multiprocessing settings" or "optimum PC" yielded no results.


            But today I am rendering 1080i  quicktimes- flipping the frame rate to 29.97 and creating .avi files with the MATROX HD I-frame codec

            (codec&format is required for files for the "Crossfire" clip player by Click Effects in our control room)


            So this seemed like it should be a simple enough render to take adcantage of my 64GB of RAM- but it has used 7 - 10% of my RAM only.

            (I cant seem to post the image of the 7% used of 63.9GB image like the above picture for some reason)

            • 3. Re: MAXIMIZING my RAM
              StevRo Level 2

              @Panthers, The machine is a great workstation but what you have is over mounted for the adobe products..  If you want to use more ram, change your project bit-depth (default is 8bit) and/or work with larger comp sizes (3-5k).  As @Mylenium stated ensure that the effects you are using are multi-processing friendly in order to max use of multi-processing.


              Hope it helps

              • 4. Re: MAXIMIZING my RAM
                Mylenium Most Valuable Participant

                You are converting framerates. That is a temporal operation. And simple limitations from the primordial age of computers will prevent multiple programs from writing to the sam, file, anyway. So you can only process one file at a time and all frames sequentially for that matter, which easily explains the limited use of your resources.



                • 5. Re: MAXIMIZING my RAM
                  Todd_Kopriva Level 8

                  That message about "11% used" is only referring to the RAM used by the foreground application; it has nothing to do with the RAM used by background rendering processes, et cetera. In other words, ignore that message; it's misleading.


                  >  Searching the forum for  "ideal multiprocessing settings" or "optimum PC" yielded no results.

                  See this:

                  FAQ: What are optimum memory settings for best performance in After Effects CS4, CS5, CS5.5, & CS6?