9 Replies Latest reply on Mar 21, 2013 4:30 PM by Michael Brownjohn

    Canon C100 AVCHD workflow

    AHAp Jonathan Level 1

      Hi! Have just gotten the first footage from the Canon C100 and was eager to edit it in Premiere CS6. When scanning around different forums, the best way to set up the project seems to be making a 1080i50 sequence since the footage from Canon C100 is 25p wrapped in a 50i-file. The trick was to click the "display both fields"-option in the viewer-options to get the full 1080-resolution glory. However, while this way of working the footage lookes great when only editing different video files, it looks bad when animating a video-track, a title and so forth. Displaying both fields makes the motion look very wierd and jagged interlace-lines appear, the footage itself tho gets maximum resolution. If using an ordinary AVCHD 1080p25 sequence you loose resolution and also gain Aliasing, not very nice.

       

      So the question is, how do you set up a project correctly for C100 25p footage that is wrapped in 50i without getting trouble when animating objects?

        • 1. Re: Canon C100 AVCHD workflow
          Alan Craven Level 4

          Despite the interlaced wrapper, the files still need to be treated as progressive since both fields are identical since they are created from the single opening of the shutter.

           

          Have you tried using interpret footage to force Premiere to recognise your files as progressive?  their is a flaw somewhere in either Premiere or the Canon file system which means that Premiere does not recognise these AVCHD files as Progressive.

           

          R click on the file in the Project panel, select Modify > Interpret Footage, followed by select Conform to, and change this to "No fields (Progressive Scan)".  You can do a batch by highlighting them all.

          1 person found this helpful
          • 2. Re: Canon C100 AVCHD workflow
            AHAp Jonathan Level 1

            Thank you for your answer! I have seen that solution that seem to work on some AVCHD-footage. However, when doing this on the C100-footage you loose a lot of resolution and gain aliasing hell. Very wierd indeed. I have also try running the files through ClipWrap, though that doesn't seem to do the trick either. If I convert the .mts to prores through ClipWrap, it creates a nice workable file, but not when "rewrapping only" to .mov.

             

            So while converting all footage to prores does work, it also means you have to buy 4 times as much storage witch isn't very economical in the long run.

            • 3. Re: Canon C100 AVCHD workflow
              Alan Craven Level 4

              Sorry.  I didn't realise use were using a Mac.  My solution wotked on a PC with files from a Canon HF S30. I thought the same solution might work with your Canon files.

               

              There seem to be all manner of problems around at the moment with the PsF pseudo-progressive AVCHD files.

               

              If you have not seen it yet, it is worth having a look at the series of articles by Allan Tepper on the Provideo Coalition web site.

               

              This may not work for you either, but what sequence preset do you get if you drag one of the files onto the "Make New Item" icon at the bottom of the Project Panel?  For me, it comes up with AVC Intra 100, but interlaced rather than progressive.  I have used an AVC Intra 100 25p preset with good results

              • 4. Re: Canon C100 AVCHD workflow
                Fadil_Basymeleh
                • 1st, create new sequence: AVCHD 1080p 25p
                • 2nd, intepret footage as Alan Craven suggest above. (right click media > modify > interpret footage > conform to : No Fields (Progressive Scan)
                • 3nd, turn off Mercury Playback Engine GPU/CUDA, select Software Only (Menu > Project > Project Settings > General
                • 5. Re: Canon C100 AVCHD workflow
                  mtnski

                  Why do you turn off Mercury Playback Engine?

                  • 6. Re: Canon C100 AVCHD workflow
                    Raphaelinator

                    I tried the Settings above but they didn´t help me....it still jerks all the time.

                     

                    With the following Settings it works fine!

                     

                    Sequence= AVC INTRA/1080I/AVC-I 100 1080I50

                    Footage: Original (1st Field First)

                    SourceMonitor: Rightclick/Field/Show First Field

                    Program Monitor: Rightclick/Field/Show First Field

                     

                    Don´t change the Mercury Playback Engine, it should use the CUDA-Option!

                     

                     

                    I have a MacPro with QuadCore and NVidia Quadro 4000 2048MB and 32GB RAM.

                    And Adobe CS6!

                     

                    Cheers, Raphael

                    • 7. Re: Canon C100 AVCHD workflow
                      AHAp Jonathan Level 1

                      Thanks for you answer! When I try this setting, I get a lot of aliasing in the source- and program-monitor. However when changing fields to "Display both fields" in the monitors, it seems to show the footage correctly.  Do you get aliasing as well? Haven't had time to evaluate speed-difference though. But it really is very bad that your MacPro can't cope with the footage with the other settings! We have a Mac Pro here as well and when editing XDCAM footage in FCP there is no problem. AVCHD in Premiere CS6 though, you get some jerky footage at times. Very annoying. I am however using a MacBook Pro latest model.

                      • 8. Re: Canon C100 AVCHD workflow
                        Michael Brownjohn

                        Have tried all the advice with not much luck.

                         

                        If you use: AVC INTRA/1080I/AVC-I 100 1080I50, images and animation is interlaced on export to progressive.

                         

                        If you use a progressive workflow and interpret the files, motion is interlaced within Premiere Pro.

                         

                        None of the solutions here seem to fix the issues altogether - needs to be an update so that Premiere Pro recognises the 50i wrapper as 25p without interlacing the footage in the timeline.

                        • 9. Re: Canon C100 AVCHD workflow
                          Michael Brownjohn Level 1

                          Tried this, but you get interlacing on motion still