3 Replies Latest reply on Nov 26, 2012 2:26 AM by Krischu

    TOC window empty

    Krischu Level 1

      In RH9 I'm trying to repair a project after I had modified a couple of folders and filenames outside the project.

      I went through several cycles of deleting the cpd file and reediting a couple of .apj, hhk and hhc files. Also deleted the .xpj file to start over with the original .hhp file.

       

      Some may know the hassle one can to to oneself. Anyway, at the moment my TOC  window is blank, although the .hhc file contains the structura information I can the hell not get this structure to show in the TOC window.

       

      Could it be that something stubborn is in the .cpd file that I cannot get around? It would be a tedious process to recreate the TOC manually.

       

      So I'd be grateful for any advice.

       

      --

      Christoph

        • 1. Re: Index window empty - index lost
          RoboColum(n) Level 5

          Do the .hhc and .hhk files have the exact same file name as the project? If you've been messing around with these files (inlcuding the XPJ) it could be that they are out of sync.

          • 2. Re: Index window empty - index lost
            Captiv8r Adobe Community Professional & MVP

            Hi there

             

            The first advice you probably already learned from the School of Hard Knox. Don't monkey with files behind RoboHelp's back!

             

            But we do need to make a clarification. Your post is titled as having an issue with the Index. But you talk in the body about the TOC. Is it the Index or the TOC? Or both?

             

            Cheers... Rick

            • 3. Re: Index window empty - index lost
              Krischu Level 1

              Yes I know it's playing with fire messing with files behind RHs' back. But I have no choice at the moment. I learnt that using fielneames/project names with hyphens, underscores and blanks in them is supposed to be the cause of making MS HTML Help fail.

               

              So I build some sed/grep scripts changing all filenames and filenames in the apj, xpj, hhc,hhk and what not files. It worked on most of the projects, but at the moment I'm stuck with one where the TOC is empty, and it's indeed the TOC window. sorry, I mixed this up in the title.

               

              RoboColum(n): Yes, the names match.

               

              --

              Christoph

               

              Could a moderator perhaps change the title from Index to TOC?

               

              P.S. Got it working again:

              False alarm. It's still not working.

               

              Last Info: I got it working by copying back configuration files one after another into the project from a backup

              and it works now. Don't know what the actual culprit was but would be fruitless to investigate it further since

              I have other burning problems.