13 Replies Latest reply: Nov 30, 2012 7:04 AM by Eneg09 RSS

    LR 4.2 won't read CR2

    Eneg09

      LR 4.2 won't recognize CR2. LR 4.1 did. Same card, Canon 50D, Windows 7. What's the fix?

        • 1. Re: LR 4.2 won't read CR2
          Keith_Reeder Community Member

          More information, please - what actually happens when you try to import?

          • 2. Re: LR 4.2 won't read CR2
            Eneg09 Community Member

            As a test I shot both jpeg and RAW. LR 4.2 will recognize the jpegs and import them, but does not recognize that there are any RAW images there. So I tried it with another camera (Canon 40D) and different card, and just did one RAW shot. LR 4.2 wouldn't recognize that there was anything there. But it is.

            • 3. Re: LR 4.2 won't read CR2
              thedigitaldog CommunityMVP

              Try shooting and importing JUST a raw file. Any difference?

              • 4. Re: LR 4.2 won't read CR2
                JimHess CommunityMVP

                One of your Lightroom preferences is to treat JPEG and raw files as separate images.  I don't know if that has any effect here because I usually just shoot one or the other.  But make sure that option is selected.  Also, are you trying to import directly from the camera?  Have you tried copying the images to the hard drive and then importing from there?

                • 5. Re: LR 4.2 won't read CR2
                  Eneg09 Community Member

                  Quick Conclusion: I'm abandoning LR 4.2. It has some kind of a a glitch, and Adobe will eventually find and fix it. I have LR 4 on two computers (laptop and desktop). I download photos directly into a file on the hard drive from a card reader. Even just one isolated RAW (CR2) image in a file was not visible to LR4.2 (Andrew, I tried that yesterday). So now I have uninstalled LR4.2 on the laptop, reinstalled LR4.0 (checked it out, and it imported the single CR2 image just fine), then updated LR 4,0 to LR 4.1. LR 4.1 imported the CR2 image, and then (hooray!) all the images, RAW and jpegs. So I'm back to my starting point, and now I'll leave well enough alone. I don't have brand new cameras anyway, and it's unlikely that LR4.2 has any fixes I actually need or want. Thanks again for your upport. It's very much appreciated.

                  • 6. Re: LR 4.2 won't read CR2
                    bconnerphoto Community Member

                    Lightroom 4.2 works great with my Canon 40D raw files.  But, if giving up is the best for you, then so be it.

                    • 7. Re: LR 4.2 won't read CR2
                      ssprengel CommunityMVP

                      There’s nothing for Adobe to fix if they can’t repeat the problem.  Can you upload one of your files to www.dropbox.com or another similar large-file storage location, and post the public download link, here?   Are you on the latest camera firmware?

                      • 8. Re: LR 4.2 won't read CR2
                        Eneg09 Community Member

                        Two computers, two cameras and two cards? it's not the file. Let's content ourselves with a flag on the play. Unless it happens to someone else, it's just an isolated anomaly. I have four computers operating. Each does weird things sometimes. Frustrating, but that's life. Move on.

                        • 9. Re: LR 4.2 won't read CR2
                          Mandhir Bhatia Employee Hosts

                          Eneg,

                           

                          It seems that the ACR cache is either corrupt or the whole plugin might have got some corruption.

                           

                          You can go ahead and delete the Lightroom x Catalog Previews.lrdata by following the location from the link below accrding to the OS. (x denotes version)

                           

                          http://helpx.adobe.com/lightroom/kb/preference-file-locations-lightroo m-4.html.

                           

                          After relaunch if it still doesnt show the images try uninstall and reinstall of Lightroom by removing it from Programs & features if on Win 7 or from Add & Remove in Windows XP.

                           

                          If you are on mac just take the Lightroom complete file and trash it & directly install the most recent update of Lightroom.

                           

                          Mandhir

                          • 10. Re: LR 4.2 won't read CR2
                            Eneg09 Community Member

                            Thanks for the suggestion and you're probably right. I did uninstall and reinstall LR to get me back up to LR 4.1, so I'm operational and can coast for awhile. Eventually my scientific curiousity will compel me to see if LR 4.2 will cooperate. However today, like Don Quixote, I must ride off to tilt at other windmills.

                            • 11. Re: LR 4.2 won't read CR2
                              Mandhir Bhatia Employee Hosts

                              Eneg,

                               

                              As per the Adobe documentation below the your camers is supported so you shouldnt have any more issues after this.

                               

                              http://www.adobe.com/in/products/photoshop/extend.html

                               

                              The issue could have been the corruption of the ACR.

                               

                              Mandhir

                              • 12. Re: LR 4.2 won't read CR2
                                ssprengel CommunityMVP

                                What would a Photoshop plug-in called ACR have to do with Lightroom?  I don’t think the user even has Photoshop installed.  LR does use the ACR-cache location, but there is no plug-in to be corrupted as you suggest in the first sentence.

                                 

                                How would LR preview-cache corruption make things not work in LR 4.2 but work ok in LR 4.1 using the same catalog and cache locations?  Is LR 4.2 more susceptible to cache corruption than LR 4.1?

                                 

                                My interpretation of the user’s symptoms, from the initial description, is that during import, no raw files are shown on the import grid prior to import, only JPGs as if there are no raw files on the camera memory card being imported from even though there are, and that this happens with images from two different cameras, on two different computers, and the previews in the Import grid only come from the files, themselves, not from any preview or ACR cache, right?  It is like there is a filter on the import filetypes to exclude raws, but include JPGs.

                                 

                                If the symptoms are actually that the images all show up on the Import panel and are imported into LR, and afterwards that the raw files show as gray squares while the JPGs are ok, then cache corruption could be an issue, except that the cache seems fine in LR 4.1, so that isn’t as likely the problem.  If both raws and JPGs are imported into LR but only JPGs are visible, then there could be some sort of file-type filter enabled, but that’s unlikely to occur for every NEW import, unless things are all being imported into the same folder in LR, but even if there is a filter like this, the filter should operate the same in LR 4.1 where raws are visible and LR 4.2 where raws are not visible, assuming the user is using the same catalog for both LR 4.1 and LR 4.2.

                                • 13. Re: LR 4.2 won't read CR2
                                  Eneg09 Community Member

                                  Thanks. You understood all my symptoms pefectly: LR 4.2 wouldn't recognize that there were CR2 images to import, but LR 4.1 did, and does so again. LR 4.2 only saw the jpegs.

                                   

                                  For what it's worth, I do have PS CS6 installed on both computers (plus the rest in the Creative Suite, primarily for InDesign and Illustrator which I use a lot.) Maybe I have some other non-Adobe software that LR 4.2 doesn't like. And maybe LR 4.2 didn't do any upgrade that my trusty ol' Canon 50D needed anyway. So for now I'm operational, happy and coasting.