2 Replies Latest reply on Nov 30, 2012 4:44 PM by chris.campbell

    Permission Issues

    xoCTM

      OK, after a Windows reinstallation I'm getting some serious issues installing/running flash player. I'm on 32bit Windows XP SP3. I'm pretty sure before the format I had a bit older Flash release. I'm using administrator account yet still Flash Player won't install correctly. At about 50% it returns "general installation error". It was the same with both ActiveX and Plugin. I checked many possible causes and solutions. Finally decided to check running installers with "run as" function and selected the account I was loged on. It worked. It's strange as I was loged on that account (again - with all the admin permissions) anyway. So, using this method I managed to install Flash Player for both IE8 and Opera (my main browser), but then some other issues appeared. While Flash works fine  under IE, Opera keeps crashing each time, for instance - a video is loading. Again, decided to run Opera using "run as" and again picked my account name and yet again everything works fine this way. I rechecked all my permissions multiple times and everything is fine. I've never had to edit them much really in the past and never experienced such issues with Flash. There is clearly something wrong here. Any ideas, any solutions?

        • 1. Re: Permission Issues
          xoCTM Level 1

          Alright, after hours spent tracking this problem and testing I got it nicely solved. Thank god I had clean install of Windows, else it would be a real damn pain to figure out where to even start. Anyway, issues were caused by AtiTrayTools, by its OnScreen Display feature to be exact. It somehow conflicts with both - Flash Player installation process and Flash Player in use. I basically created new user account and did some testing step by step. In short - disabling OSD feature in AtiTrayTools solved all problems (requires either reloging to your Windows account or rebooting the system after). I even reinstalled both FP plugins, everything went fine. I still find it pretty odd, as I'm sure I had OSD feature running once in a while on my old OS installation and didn't have any issues like these. But on the other hand, it's possible it was due to some other system settings, that prevented conflicts to occur.

           

          To summarize:

           

          Sympthoms:  Flash Player fails to install, at about 50% returning "general installation error". Browser crashes when loading Flash Player videos.

           

          Cause: AtiTrayTools OSD feature.

           

          Solution: In ATT go to "Tools & Options" --> "OnScreen Display", uncheck "Enable OnScreen Display",  press "Ok", relog to your Windows account or reboot the system.

           

          Hopefully it will help people having similar issues in the future. Adobe's staff might want to add it to FAQ as well.

           

          Regards.

          • 2. Re: Permission Issues
            chris.campbell Adobe Employee

            Excellent, thanks for posting back with this solution!  I'll make note of this in case I run into this in the future.

             

            Chris