3 Replies Latest reply on Dec 5, 2012 2:48 AM by RoboColum(n)

    RH10 > WebHelp > TOC/Glossary/Search not working in IE9 via HTTPS

    Michael Hunsberger

      We recently upgraded from RH8 to RH10, and almost immediately encountered (what appears to be) an old issue.

       

      Using Adobe TCS 4.0, we create our content in FrameMaker 11, then link to Robohelp. After generating Webhelp, we tested the output from a local machine. Everything worked as expected.

       

      We then checked the files into Microsoft TFS and hosted the Webhelp on an HTTPS server. However, when we tested the output using Internet Explorer 9 and Chrome 23, we found that:

      1. Table of Contents does not display.
      2. Glossary (which we've renamed to Acronyms) does not display.
      3. Search does not work (from either Search tab or quick search bar).
      4. SWF files (from Adobe Captivate) inserted into topics do not appear or play.

       

      We don't use an index, but I assume that would not work either. I've attached screenshots so you can see the problem:

      test_img.jpg

       

      Adobe previously released a fix for the whutils.js file for RH8 and RH9, which used to be hosted here: https://acrobat.com/#d=WqbdTq-2R79ToU08-zfBEw (link now broken). I am assuming it is a similar issue with a similar fix. I will file a bug report, but I wanted to see if the community had any quick fix since we're on deadline.

       

      You can see the full forum history here: http://forums.adobe.com/thread/822754?tstart=0

        • 1. Re: RH10 > WebHelp > TOC/Glossary/Search not working in IE9 via HTTPS
          archerdc

          I'll first identify myself as Michael's colleague, and then add two more things:

           

          1. When I point my mouse to the hyperlinks behind any of the offending components (i.e. the Content or Acronyms tab above, and the Search button to execute a search, IE displays "javascript:void(0);" - something is preventing the browser (IE9) from rendering these components. We are deploying to a US Govt customer, which means there are some additional restrictions in place in that environment - but as Michael stated, these same projects worked with RH8 and RH9 once Adobe released the patch for whutil.js.
          2. SWF files also do not render in the individual topics in this environment. It's possible this is a separate bug, but they too have worked fine in the past and are working now in all other environments.
          • 2. Re: RH10 > WebHelp > TOC/Glossary/Search not working in IE9 via HTTPS
            archerdc Level 1

            So after engaging our development team, we have resolved the issue for the present.

             

            We had two new variables with our process for this release:

            1. First time using TCS4 (prev 2.5)
            2. First time checking files in directly to Microsoft TFS using Visual Studio Source Control (previously zipped WebHelp, posted to SharePoint, sent link to developers).

             

            As it turns out, the second variable is the culprit here. RH is off the hook for now. For reasons yet unknown, Visual Studio was excluding files (without notice) from checkin. Once we performed an additional step (right click Visual Studio directory > Add Items), it picked up the missing files and everything worked as expected in the staging / QA environment.

             

            The missing file was WebHelp > resource > resource_.xml.js.

             

            Next step on our end is to test the integrated RH > TFS Source Control. We didn't (thought we didn't) have enough time to test publishing WebHelp directly to TFS using the RH 10 plugin - not sure if it would make a difference or not. We'll test that properly between releases and see if it works or not.

             

            Very, very strange though that Visual Studio would behave that way over such a simple, every day version control procedure. My dev team is flummoxed - and these guys are good enough for that to be a genuine rarity.

            • 3. Re: RH10 > WebHelp > TOC/Glossary/Search not working in IE9 via HTTPS
              RoboColum(n) Level 5

              Thanks for the update Daniel. Feel free to update this thread if you find anything esle out with the RH / TFS integration testing.