0 Replies Latest reply on Dec 7, 2012 1:46 PM by JesseSchluntz

    Gspeed ES Pro RAID keeps disappearing from Mac, have to re-initialize!

    JesseSchluntz Level 1

      UPDATED VERSION:

       

      MAC PRO KEEPS LOSING CONNECTION TO RAID DRIVE.

      After 9 months of organizing a documentary film edit on an external RAID drive (12TB, Raid 0. Yes, I have 2 layers of backup), I purchased the PNY Nvidia Quadro 4000 video card for the primary edit. Soon after, I began having boot up issues. The screen would freeze at various points during the startup process, requiring manual power-downs.

      Over the past two months, my computer has lost communication with the RAID 3 times, forcing me to rebuild it from my backup drives (10TB). One tech at Diskwarrior said my computer lost the partition, and that the 1s and 0s had been largely replaced with gibberish.

       

      The Raid becomes unrecognized by my computer in one of two ways:

       

      1. 1-    After two days of copying data back over to the raid (rebuilding it), I get an error code -36, saying a file cannot be read or written, then the Raid partition disappears from disk utility and the next time I start up the computer says it doesn’t recognize my drive. The ATTO configuration tool (the card that attaches my raid to the computer) sees the drive, but my computer does not. I have to re-initialize it and start over again.

       

      2-    The Raid will go from being recognized to not being recognized when I reboot one day. Again, I have to re-initialize and rebuild.

       

      I removed the PNY Graphics card and put in the stock ATI Radeon HD 5770 it came with. On day 2 of rebuilding the RAID, I got the error -36 and the Raid disappeared from disk utility again. When I opened the raid folder, which seconds before had 10 TB of data on it, it read as zero items. So the PNY Nvidia card was NOT the problem.

       

      Apple has worked on the computer 3 times, running extensive hardware tests, but the same problem persists. At one point they said my blackmagic card was the problem, and more recently they said I probably have bad ram. I tried separate ram (the old 6GB my computer came with), and my computer seemed to begin booting up okay, but one day later I had the -36 error, the RAID couldn’t be recognized again and I lost the data during another rebuild. Apple even replaced the Ram Tray, but the same problem persists.

       

      G technology says my RAID’s hardware is fine, and ATTO, who makes the Raid card, says it looks fine to them too. This does not mean they are 100% not the problem though.

       

      Yesterday as I was attempting to rebuild the RAID again, I saw the -36 error come up, and files stopped copying. I immediately made a screenshot and noted the time.

       

      Today I spoke with a really cool tech at Apple named Ron who helped me investigate the Kernel log, and this is what it said (the RAID is called FadingWest):

       

      Dec  6 17:05:36 Jesses-Mac-Pro kernel[0]: hfs_swap_BTNode: invalid forward link (0xbb739311 >= 0x0000df00)

      Dec  6 17:05:36 Jesses-Mac-Pro kernel[0]: hfs: node=2717 fileID=4 volume=FadingWest device=/dev/disk3s2

      Dec  6 17:05:36 Jesses-Mac-Pro kernel[0]: hfs: Runtime corruption detected on FadingWest, fsck will be forced on next mount.

       

      Ron believes my problem is with the RAID card. He thinks it’s dropping the connection. So I’ve got an RMA going with ATTO for a new one.

       

      Here are the final things I can troubleshoot at this point:

       

      • New RAID card (ATTO)
      • New RAID drive (G-Technology)
      • Motherboard / PCI lanes (Apple).
      • NEW COMPUTER (Apple)

       

      Any ideas are appreciated. Here are the items in question:

       

      • Mac Pro mid 2010 2x2.66 Ghz 6 core Intel Xeon OS X Lion 10.7.5
      • G speed ES Pro (G Technology) – 12TB @ RAID 0
      • ATTO R680 RAID card