1 Reply Latest reply: Dec 7, 2012 5:08 AM by Rave RSS

    aDOBE aCROBAT 5

    sharky_moriarty Community Member

      aDOBE aCROBAT APPARENTLY IS NOT COMPATIBLE WITH wINDOWS 7. wHAT DO i NEED TO DO?

        • 1. Re: aDOBE aCROBAT 5
          Rave Employee Hosts

          Hi Sharky_moriarty,

           

          Acrobat 5 is a very old version and is incompatible with Windows 7.

          Please buy the latest version Acrobat XI. It would cost you around $449 USD.

          But you can also opt for monthly subscription that would cost you just $29.99USD.