8 Replies Latest reply: Dec 9, 2012 11:21 AM by Cayce RSS

    Merging Layers Discards Bevel Effect

    Cayce Community Member

      Been dealing with this for a while, and it appears others have also, according to research. Layers with a layer style applied, mostly of the bevel or emboss variety, lose the effect when the layers are merged or the image flattened. Doesn't seem to happen with any other styles, like drop shadows or glows: those will stay, but the bevel will not. These are all Normal layers, nothing tricky going on. It's a program fault and I need to know if there's a workaround. I'm having to resort to saving the whole unflattened image as a jpeg so the client can proof the work, but sooner or later I'm going to need to flatten the image.


      Using Mac PS CS5 Extended, abundance of RAM & Disk space.


      Thanks for any help.



        • 1. Re: Merging Layers Discards Bevel Effect
          Noel Carboni Community Member

          The only problems I know of that people are having with effects and merging / flattening is that they try to judge appearance at zoomed-out sizes, and effects are only approximated in that condition.  The general advice is to judge your effects at 100% zoom.


          If you are seeing effects lost when merging or flattening and that can be seen at 100% then please take some screenshots (showing everything) and post them here.  Perhaps you have an interesting set of blending modes that's somehow hiding your effects.



          • 2. Re: Merging Layers Discards Bevel Effect
            Cayce Community Member

            Ok. I've attached a screen shot comparison, Before & After. The Text layer is part of a group folder containing the brushed metal ring it overlays. In order to eliminate the vector factor as a possiblity, I rasterized the text, then added the emboss effect, before merging the group. This merge and loss of effect on the text happened at 100%, full working resolution of the art. Here's the image:






            • 3. Re: Merging Layers Discards Bevel Effect
              Noel Carboni Community Member

              Undeniably you're seeing a change there.


              I still can't help but think there's an issue where a layer effect is being approximated when you're viewing the layered document, but when it's actually applied it's different.  There IS a hint of the bevel still in the right image.


              It would have been more helpful to be able to see more - e.g., your layers panel, specifically, the layer blending modes, etc. for the involved layers.


              But rather than that, ideally, could you crop out just the part of the image you're showing here from your layered document, save it as a PSD file, and post it online?  I would be happy to download it, try to reproduce the problem.  With something like this it may be the only way to nail down what's happening.


              Remember to check the Delete Cropped Pixels box.



              • 4. Re: Merging Layers Discards Bevel Effect
                Cayce Community Member

                Ok... I'm going to send the PSD file. I've stripped it of all unnecessary layers and cropped for portability, but it's still having the same effect. Try collapsing the ArchedText group into one layer and watch the text emboss disappear. What's also interesting is that even though the text has been rasterized, bitmap just as the Metal Ring art, the Metal Ring group will collapse with the style intact, but the text won't. The only difference is that the Metal Ring art style is an inner bevel, where the text style is a pillow emboss.


                The file exceeds the weight limit here. It's 6.6mg. Here's the download link:



                Do appreciate your help on this.



                • 5. Re: Merging Layers Discards Bevel Effect
                  ja3754 Community Member

                  I think the problem could be that you are not viewing the file at 100% zoom, as Noel suggested above.


                  If I view the file at 16.67% and then flatten layers, I see a change in the bevel on the letters similar to your screenshots. But there is no change in appearance when flattening at 100%. The size of your screenshots suggests you are zoomed out.


                  [PS CS5 standard 12.04, Mac 10.6.8]

                  • 6. Re: Merging Layers Discards Bevel Effect
                    Noel Carboni Community Member

                    The real issue, I believe, is that the layer effect can only use integers, and when it's attempting to show you how it will look when zoomed out to, say, 25%, it can only use a bevel size of 1 pixel.


                    Zoom out in stages and watch the significant change in appearance from 33% to 25%.


                    Your solution is simply to increase the size of the bevel (e.g., from 6 to 16 pixels) so that it looks larger at 100% zoom, and the same when zoomed out.



                    • 7. Re: Merging Layers Discards Bevel Effect
                      Cayce Community Member

                      Well, that's very weird, though it seems to have worked. It's still a problem, though, having to keep in mind to compensate for the pillow emboss effect in a +/- zoom rendering, when this doesn't happen with other effects I've used (haven't been through them all, but inner & outer bevels work fine). I'll play with it and see.


                      How come PhotoShop can't be perfect like the rest of the world? 


                      You took a bit of time helping me through this, and I thank you. Great assist.





                      • 8. Re: Merging Layers Discards Bevel Effect
                        Noel Carboni Community Member

                        It does happen with other effects too.


                        As far as making it more perfect, there is a configuration change you can make that will make Photoshop calculate everything at 100% size under the covers, then downsize for display, but it comes with some possible nasty side effects.  For one, since it's doing everything at full size it may slow WAYYY down, and for another not all GPUs can handle it.  But if you want to try, the configuration change is this:  In the Performance Prefs, change Cache Levels to 1, then close and restart Photoshop.


                        Please be aware that this may destabilize your system, and if you find yourself thinking "wow, this is sluggish!" you'll know why.


                        I actually use this setting for my 32 bit Photoshop only (I'm on Windows), because it also causes layer compositing to be done in full 16 bit precision (which I find useful for astroimage processing).  The nice thing is that the two versions (32 and 64 bit) keep their configurations separately, so all I need to do to get high quality compositing is just run the 32 bit version.


                        More than you wanted to know, probably.