3 Replies Latest reply on Dec 16, 2012 12:05 PM by BKBK

    Windows Server 2008 Conecting to Coldfusion 9 Tags

    piggles

      Im having a problem attaching to Windows server 2008 with the exchange tags in coldfusion 9.
      We took the username and password out and we get a access denied error.
      We put them in and we get the following screenshot error.

       

       

      Here is the code I am working with

       

      <CFEXCHANGECONNECTION

        action="open"

        username="windowsusername"

        password="windowspassword"

        server="10.10.10.6"

        connection="conn1">

       

      <!--- Create a structure with the task fields. --->

       

      <CFSET stask = StructNew()>

      <CFSET stask.Priority = "high">

      <CFSET stask.Status = "Not_Started">

      <CFSET stask.DueDate = MakeODBCDate("08/10/2012")>

      <CFSET stask.Subject = "Johns Task Test">

      <CFSET stask.PercentCompleted = 0>

      <CFSET Message = "Hello John!">

       

      <!--- Create the task by using a transient connection. --->

       

      <cfexchangetask action = "create"

        connection="#conn1#"

        task = "#stask#"

        result = "theUID">

       

      <CFEXCHANGECONNECTION

        action="close"

        connection="conn1">

       

      When run I get the error “Unable to connect to the Exchange server using HTTP/HTTPS protocol”

       

      coldfusionexchangeerror.JPG

       

      I am assuming it’s a setting somewhere, but I wouldn’t have a clue where to look.  If you could help I would be very grateful.