2 Replies Latest reply on Aug 3, 2006 6:59 AM by pumakino

    Problem accessing Webservice

    pumakino
      Hi,

      I am a complete newbie at Flex so please be patient with my questions. I am a .NET developer and am trying to bind the result I get from my webservice to a simple text box.(yes its a typical HelloWorld app)

      The mxml code is as follows :

      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" layout="absolute"
      creationComplete="kino.SayHello.send()">
      <mx:WebService id="kino"
      wsdl=" http://misdevservices/wsCommon/Options.asmx?wsdl"
      useProxy="false">
      <mx:operation name="SayHello"></mx:operation>
      </mx:WebService>


      <mx:Panel x="21" y="10" width="350" height="400" layout="absolute" title="Hello World Test">
      <mx:Text x="10" y="37"
      text="{kino.SayHello.result}"
      width="217" height="40" id="txtDisplay"
      fontFamily="Verdana" fontSize="16" fontWeight="bold" color="#1d8322"/>
      </mx:Panel>

      </mx:Application>

      The webservice is hosted on a virtual Windows Server. I have created and placed the crossdomain.xml file in the root folder of the server as well but when i run this application, neither do i get any error messages, nor do i get the result back!!! I am not sure what I am doing wrong and if i need to make any configuration changes? I would be very obliged if someone could point me in the right direction.

      The SayHello method of the webservice doesn't take any parameters and is returning a string. Text