2 Replies Latest reply on Dec 19, 2012 1:03 AM by intrasec.bm

    Could not create object named "InDesign.Application.CS5"

    intrasec.bm

      Hello,

       

      I am experiencing an error when trying to start Indesign CS5.5 via a .vbs script.

       

      The script contains the line:

       

         SET my_app = WScript.CreateObject("InDesign.Application.CS5")

       

      When the script runs, InDesign starts properly, but after what seems to take 1~2 minutes, I get ths error message:

       

      InddPb.png

      The translation of this error message to English is: “Could not create object named "InDesign.Application.CS5"”.

       

      The error is the same when I use the names “InDesign.Application” or “InDesign.Application.CS5.5”.

      When WScript.exe terminates, InDesign.exe also terminates.

       

      I am wondering why the script does not respond.

       

      I tried also via C++ and the MFC libraries to create an object :

       

      If I have an “Application” class, deriving of COleDispatchDriver, and imported from the type library, then Application::CreateDispatch("InDesign.Application", &e) returns nonzero value, and the exception passed by pointer is filled with the same error message.

       

      Is there something I miss?

       

      Let me precise that InDesign is installed via an SCCM package and that I do not know what that package exactly does.

       

      Thanks