4 Replies Latest reply on Jul 15, 2006 9:18 PM by Newsgroup_User

    Web services: Error in the first step

    Level 7
      I am testing web services with ColdFusion and stuck in the first step. I've
      copied several coding examples from online and am having all the same errors
      when I tested locally on my laptop. But when I tried the files on real
      website of my office, it shows the result string with problem. So I assume
      I need some kind of server side configuration. My laptop is on Win XP and
      the office server is on Win 2000 and both of them are running on IIS.

      This is one of the files I tried.

      "helloworld.cfc" file =>
      <cffunction name="getMessage" access="remote" returntype="string"
      <cfargument name="name" type="string" required="yes">

      <cfreturn "Hello " & arguments.name &"! " & "I've been invoked as a web

      "helloworld.cfm" file =>
      webservice=" http://localhost/tutorial/ColdFusion/template/webservices/helloworld/helloworld.cfc?wsdl"
      <cfinvokeargument name="name" value="Rob"/>


      And this is the error message when I tried locally.
      Error Occurred While Processing Request
      Could not generate stub objects for web service invocation.
      org.xml.sax.SAXException: Fatal Error: URI=null Line=1: White spaces are
      required between publicId and systemId. It is recommended that you use a web
      browser to retrieve and examine the requested WSDL document for correctness.
      If the requested WSDL document can't be retrieved or it is dynamically
      generated, it is likely that the target web service has programming errors.

      Can anyone give a clue to solve this problem?

      Thanks in advance