2 Replies Latest reply on Jan 2, 2013 7:32 AM by tehcodes

    iOS Simulator FB 4.7

    tehcodes Level 1

      Me

      ---

      FlashBuilder 4.7 Premium

      Flex SDK 4.6.0 w/ Air 3.5 overlayed

      Mac OS X 10.8.2

       

      I'm trying to run a small app from one of the FeathersUI tutorials. It runs fine on the Air Simulator, but once I try to run it on the iOS Simulator I get:

       

      Error occurred while packaging the application:

       

       

      Exception in thread "main" java.lang.Error: Unable to find llvm JNI lib in:

      /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/lib/adt.jar/Darwin

      /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/lib/aot/lib/x64

      /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/lib/adt.jar

      /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/lib

       

          at adobe.abc.LLVMEmitter.loadJNI(LLVMEmitter.java:582)

          at adobe.abc.LLVMEmitter.<clinit>(LLVMEmitter.java:596)

          at com.adobe.air.ipa.AOTCompiler.generateExtensionsGlue(AOTCompiler.java:419)

          at com.adobe.air.ipa.AOTCompiler.generateMachineBinaries(AOTCompiler.java:1790)

          at com.adobe.air.ipa.IPAOutputStream.createIosBinary(IPAOutputStream.java:378)

          at com.adobe.air.ipa.IPAOutputStream.finalizeSig(IPAOutputStream.java:743)

          at com.adobe.air.ApplicationPackager.createPackage(ApplicationPackager.java:91)

          at com.adobe.air.ipa.IPAPackager.createPackage(IPAPackager.java:245)

          at com.adobe.air.ADT.parseArgsAndGo(ADT.java:571)

          at com.adobe.air.ADT.run(ADT.java:419)

          at com.adobe.air.ADT.main(ADT.java:469)

       

      I've read several different forums on Adobe and I see suggestions to remove Java 7 in favor of Java 6 (this isn't really a solution). I see to overlay Air SDK 3.4+ because Flex SDK 4.6 that comes with FB 4.7 is using Air 3.1. This didn't work.

        • 1. Re: iOS Simulator FB 4.7
          08ight

          I would really like to know the solution for this problem as well i am using a mac and i have the same problem with FB and Flash professional CS6

          • 2. Re: iOS Simulator FB 4.7
            tehcodes Level 1

            I had to overlay the 3.5 Air SDK over 2 locations in the FB 4.7 app.

             

            • /Applications/Adobe Flash Builder4.7/sdks/4.6.0 - this was so that my projects all have 4.6.0 + 3.5 Air. Then I overlayed
            • /Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK - This is where the tools compile and cause the main problem.

            I hope this helps you.