3 Replies Latest reply on Dec 21, 2012 9:20 PM by Sham HC

    Migrating from WebSphere to CQSE - CQ 5.22/CRX 2.2

    jgrasett

      We are looking at migrating off of WebSphere to a CQSE environment. Currently running CQ 5.3 qwith CRX 2.2 HFP70. I have been able to get a little bit of this to work by creating a CQSE 5.3/2.2 environment, then copying over the repository and modifying the web.xml and other files for repository names and the workspace.xml for paths. I am able to acces CRX - Package Manager and CRXdeLite, but when I try to getto the site from CRXdeLite, I get classnot found messages referrinf to custom taglibs. Oddly, the main CQ login page gives our custom 404 error page, which is a bit encouraging, but obviously the felix bundles are not the same on the CQSE side as the WAS side, and copying them and config over really doesn't work.

       

      I was thinking about trying to import the missing and mismatched buindles, but thats going to be a lot of work, and am hopeing there is something easier we can do to perofrm this migration. Would making the CQSE a cluster member work I wonder? and if it did, would we be able to remove the WebSphere memeber and make the CQSE one master, and then remove clustering altogether?

       

      Any ideas or shared experiences or suggestions are welcome!

       

      Thanks!

        • 1. Re: Migrating from WebSphere to CQSE - CQ 5.22/CRX 2.2
          Jörg Hoh Adobe Employee

          As you only change the deployment structure and not the instance itself (CQ/CRX doesn't matter if it runs within WAS or CQSE), you could try the following approach:

           

          * Create a new instance of CQ 5.3/CRX 2.2 with CQSE

          * Shutdown this instance

          * Copy over the launchpad and the repository folders recursively from your WAS instance

          * make necessary changes to the start script & startup this instance

           

          Caution:

          * If you have used proprietary APIs of WAS, it probably won't work

          * If you used WAS infrastructure, it won't work. CQSE is only a servlet engine.

           

          Jörg

          • 2. Re: Migrating from WebSphere to CQSE - CQ 5.22/CRX 2.2
            jgrasett Level 1

            I have tried this, but sling does not even start. CRX starts fine in anycase, but if we do much of anything to luanchpad, sling will not start. We get a class not found for org.apachje.sling.launchpad.api.LaunchpadConentProvider - we tried replacing the org.apache.sling.launchpad.core.jar from our copy of the launchpad with one from a clean CQ 5.3 install, but then we get a raft of bundle errors and then java.lang.IllegalStateException: zip file closed.

             

            I know when we upgraded our WAS install to CRX 2.2 we replaced not only the CRX war but the CQ Launchpad one as well, and I think this has made it incompatible with a simple CQSE 5.3 CRX 2.2 build where that launchpad war file is never updated. I think we're close.

             

            Now I think I understand the root of the problem. In our WAS environemtn we followed the Upgrade to CRX 2.2 documentation and used the associated file, which contains a new crx and cq launchpad war file. I nthe new CQSE build, when I go to upgrade to CRX 2.2, I have to follow the upgrading CRX in CQ document, which has only the one new war (replacing two wars). One would think that then upgradeing the cq launchpad war ( the / module) would work around this, but it appears not. I am goi ngto work through this again to see how it goes and what errors I get.

            • 3. Re: Migrating from WebSphere to CQSE - CQ 5.22/CRX 2.2
              Sham HC Level 7

              On the fresh cq instance make sure to install the latest crx hotfix that you have installed in websphere.  Because all those jar file exists under cq_home/crx-quickstart/server/runtime/0/_crx/...