6 Replies Latest reply on Sep 7, 2013 2:03 PM by DavidAlexander

    Page numbering not working correctly in book file.

    ChrisPixelMobb

      Hi, I have been knocking my head on the wall for a few days trying to figure this out. I have set all the documents to Autonumber (from previous document). Set up section numbering in prefences. The first 2 chapters in the book fly out box works and links together to create the consecutive page numbers. The remaining chapters do not. I opened up another book I recently did to see if it was something with InDesign. It opened fine, all pages consecutively. However if I do an update all numbers, they turn into what I have here. So confused any help would greatly be appreciated. I searched the forums, online, called buddies, everyone is stumped.

       

      Attached is a image of the book fly out panel.

       

      Speedissue2.PNG

        • 1. Re: Page numbering not working correctly in book file.
          Daniel Flavin Level 4

          I'm guessing that ForwardStart is defined to Start Page Numbering at 2

          Chapters2 and beyond may have been a copy of ForwardStart with the Start Page Numbering still set to 2

          Verify that they appear as shown - Automatic Page Numbering

           

          If all else fails, create a new document, and Move the pages from the problem files to new documents

           

          Capture.JPG

          1 person found this helpful
          • 2. Re: Page numbering not working correctly in book file.
            ChrisPixelMobb Level 1

            Forward start was actually created after all the other documents. It is set to page 2 and not auto. the next one tho is set to Auto and every other chapter thereafter. Which puzzles me if the settings are all the same, why is Chapter 2 taking it and the rest not? Also if I change the Forwardstart chapter to Auto the spread completely breaks apart, and creates opposing pages, on different spreads. So frustrating, it has to be something I am missing.

             

            Correct me if I am wrong, the only areas to update these settings is either the numbering and sectioning options in the flyout drop down, or globally in the general preferences pane for numbers to start either at 1, or 2.

             

            I am trying to stay away from the MOVE workaround as I have about 100 pages and severly past deadline already. So odd I have done this a bunch of times produced books in the past, have never had this happen. The only thing I can think of is some of the previous books were ebooks, and not built with spreads, this book was build with spreads and facing pages.

            • 3. Re: Page numbering not working correctly in book file.
              Daniel Flavin Level 4

              It sounds as if you are starting with a Left Hand Facing page (inside cove page?). Hence, the head scratching for ForwardSpread. I've only had a need to do this once, this week. UnCheck allow pages to Shuffle (counter-intuitive to me) and drag page icons if it siuts your view.

               

              left hand spread.JPG

               

              Facing pages is not necessary to accomplish your book document, but is more a visual assistance in layout and possibly items crossing the spine. If it helps, and I think not, you can turn it off in the Document Setup; be mindful of anything crossing the spine.

               

              The MOVE work-around - if you indeed have Auto Numbering on, possibly the documents or the indb book filehave some corruption. You can create a new Book and load the existing documents to it relatively quickly; Moving pages from one doc to another would eliminate any document corruption. (You would need to define Auto Numbering in the new document(s))

               

              Can you post a screen shot of Chapter2 or Chapter3 Page Numbering option?  (btw, you mentiond Chapter 2 was fine; I'm going to refer to the files as listed in your original post)

               

              Message was edited by: Daniel Flavin - Turning off Facing Pages will lose any unique items on the Right Hand Master Page

              • 4. Re: Page numbering not working correctly in book file.
                ChrisPixelMobb Level 1

                Thanks for the help Daniel, I tried rebuilding the book in a new file, no go, same stuff going on first 2 chapters are fine. the rest no good. I thought you mean't actually making new files of each chapter and moving each page over to a new file.

                 

                 

                 

                chapter2.PNGCHapter3.PNG

                • 5. Re: Page numbering not working correctly in book file.
                  ChrisPixelMobb Level 1

                  Wow..... If I tell you what a noob I was being here..... I figure it out. I was going into page numbering and setting it to automatic.... never looking into DOCUMENT numbering. that did the trick. Thank you SO much for your help. I didn't understand facing pages, and the shuffle features, you helped me greatly. Happy Holidays Daniel!

                  • 6. Re: Page numbering not working correctly in book file.
                    DavidAlexander

                    Here's a clue that might help someone in the future. It took me a day and a half to figure this out even with the help of this thread—and I'm still not sure I understand it. However, I had too many changes invested to revert to an earlier version when I discovered this problem.

                     

                    What finally worked for me was: Beginning with the last document in the book I started opening them one at a time and changing the GENERAL PREFERENCES for the document to SECTION NUMBERING and then updating the numbering from the BOOK PANEL dropdown menu. (This seems counter intuitive since I wanted to see the document pages displayed consecutively throughout the book. That sounds like Absolute Numbering to me, but it probably makes sense if you understand it on a deeper level than I do).

                     

                    I doubt that beginning at the last document of the book had anything to do with it, but when I set the GENERAL PREFS for the second to last document to SECTION NUMBERING and then UPDATED the NUMBERING, all of the documents in the BOOK PANEL renumbered consecutively which then allowed the numbering in the table of contents to again be correct. WHEW!

                     

                    Thanks to all of you who've taken the time to post responses here and in other forums!