20 Replies Latest reply on Oct 18, 2006 5:41 PM by GECahn

    Contribute Connection Disabled.  Help Please!

    Cloudbrk
      When I try to connect to one of my sites in Contribute 2 or Contribute 3, I get the following error.

      CONTRIBUTE HAS DISABLED YOUR CONNECTION TO THIS WEBSITE BECAUSE AN UNKNOWN ERROR OCCURRED. FOR MORE INFORMATION CONTACT THIS WEBSITE'S ADMINISTRATOR.

      Well...the problem is...I am the administrator and I have no clue what is going on. Other sites that I have in Contribute are working beautifully. But not this one. What should I do? What can I do? Please help....angry client has called several times.

      Thanks
        • 1. Re: Contribute Connection Disabled.  Help Please!
          JamesLynn
          I have the same problem.. any help??
          • 2. Re: Contribute Connection Disabled.  Help Please!
            amadas Level 1
            Hi,

            This could be because of following reasons:

            1. Connection might have been created using domain name and client is out of domain. This way contribute cannot resolve host address.
            2. Edit the connection and get the connection url and paste it inside browser. Verify if the website url is correct. Does the URL Work?

            Try to create connection with your IP Address (Valid url, after checking in your Browser).

            Hope this helps

            Arun
            • 3. Re: Contribute Connection Disabled.  Help Please!
              websiteink
              I have the same problem - and the answer given here does not help me - partly because it either does not apply or I cannot understand it (perhaps both). Anyway, to try fix the problem (it's telling me I need to delete the connections, users, roles, etc. I did that but I am still being told that when I try to recreate the connection that my info is invalid. Perhaps, this was because at first I used my husband's name as administrator, and his email, but I really don't want it that way. I tried quiting contribute and logging over after that. Still a problem.
              • 4. Re: Contribute Connection Disabled.  Help Please!
                Tom Benjamin Level 1
                At what point does creating the connection fail?

                What method are you using to conenct to the server? FTP or Network? If it's FTP are you sure you're using the right username and password combination and the right FTP settings (e.g. "passive" FTP). If it's a network path do you have the correct permissions to access the site's root folder?

                Tom
                • 5. Re: Contribute Connection Disabled.  Help Please!
                  arao2k6 Level 2
                  Hi,
                  Also verify that the username/pass for the ftp/webdav/LAN connection you use to connect to this website has not been changed !!
                  Try creating a fresh connection to the same site.
                  • 6. Re: Contribute Connection Disabled.  Help Please!
                    tgath
                    I am also having the same issue ... I have created Keys for scores of teaches and none of them are working all of a sudden. I cannot create a connection trrough Contribute using a key or a new connection. When I do I get the "Contact the administrator error" ... All of the keys that contaim my credentials get it also. I can however log in with those creditials in Dreamweaver as well as WS FTP so the account at the server seems to be in tack. Its just Contribute thet wants me to contact myself and rectify the "Unknown Error". School starts in a week and teachers are anxious to update content ...
                    • 7. Re: Contribute Connection Disabled.  Help Please!
                      Tom Benjamin Level 1
                      Have you used Dreamweaver's test of the Contribute connection - under Manage Sites > Advanced > Contribute?

                      Contribute will need to write to the remote folder (I assume your access is via FTP), if it’s using your connection details that should work. One thing I've come across in the past is Dreamweaver being able to connect without passive FTP being enabled, but Contribute not being able to (or vice versa). When you go to Send Connection Key, choose "No, I would like to customize...", select the Advanced option beside FTP and then check or uncheck the "Use passive FTP..." option.
                      • 8. Re: Contribute Connection Disabled.  Help Please!
                        jb5968
                        Raise your hand if you are using Windows XP SP2 and are having this problem. I've been fighting this issue since May of this year, and to the best of my knowledge, Adobemedia has yet to even acknowledge that there is a problem with CT3. It seems that an IE Security Update has hindered the ability of CT3 to establish a connection and/or download the content when you try to edit a page.
                        Symptoms are: Existing connections suddenly stop working; New connections using known good connection keys can't establish a connection; Connections that work won't let you edit a page (the program stops responding while downloading content).

                        The only work-around I have been able to find so far is to replace the c:\windows\system32\wininet.dll file with a version that is compatible with CT3. Version 6.0.2900.2904 is the most recent working version I have found. Rename the old file, replace it with the new one and reboot the computer. I AM NOT recommending that you do this. I am simply stating that this is a viable work-around if you're desperate enough to get Contribute working again. The REAL fix is for the software developers to update their application to work with Microsoft security updates. http://support.microsoft.com/kb/912812

                        We are using Contribute 3.11 on a secure intranet using Windows 2003 Server with SSL enabled. The problem only ocurs with XP installations, Windows 2000 users seem to be immune...at least for the time being.
                        • 9. Re: Contribute Connection Disabled.  Help Please!
                          Level 7
                          Hello jb59,

                          Thank you so much for getting this to our notice !!
                          We will look into this and help resolve the issue. Thanks for the help ...

                          -Avinash

                          > Raise your hand if you are using Windows XP SP2 and are having this
                          > problem.
                          > I've been fighting this issue since May of this year, and to the best
                          > of my
                          > knowledge, Adobemedia has yet to even acknowledge that there is a
                          > problem with
                          > CT3. It seems that an IE Security Update has hindered the ability of
                          > CT3 to
                          > establish a connection and/or download the content when you try to
                          > edit a page.
                          > Symptoms are: Existing connections suddenly stop working; New
                          > connections
                          > using known good connection keys can't establish a connection;
                          > Connections that
                          > work won't let you edit a page (the program stops responding while
                          > downloading content).
                          >
                          > The only work-around I have been able to find so far is to replace
                          > the c:\windows\system32\wininet.dll file with a version that is
                          > compatible with CT3. Version 6.0.2900.2904 is the most recent working
                          > version I have found. Rename the old file, replace it with the new
                          > one and reboot the computer. I AM NOT recommending that you do this. I
                          > am simply stating that this is a viable work-around if you're
                          > desperate enough to get Contribute working again. The REAL fix is for
                          > the software developers to update their application to work with
                          > Microsoft security updates. http://support.microsoft.com/kb/912812
                          >
                          > We are using Contribute 3.11 on a secure intranet using Windows 2003
                          > Server with SSL enabled. The problem only ocurs with XP
                          > installations, Windows 2000 users seem to be immune...at least for the
                          > time being.
                          >


                          • 10. Re: Contribute Connection Disabled.  Help Please!
                            HandymanJay
                            JB59- It is all well and good to tell me to rename that .dll file and rep-lace it with "the new one," but what is the new one with which I am to replace it? Exactly where do I find (or download) the new file?

                            Sorry, but I came into this discussion in the middle, but it seems to be exactly what I am looking for.
                            • 11. Re: Contribute Connection Disabled.  Help Please!
                              Level 7
                              > JB59- It is all well and good to tell me to rename that .dll file and
                              > rep-lace it with "the new one," but what is the new one with which I
                              > am to replace it? Exactly where do I find (or download) the new file?
                              >
                              > Sorry, but I came into this discussion in the middle, but it seems to
                              > be exactly what I am looking for.
                              >


                              Hi,

                              In fact i thought this was the issue, But i am unable to get it on my machine.

                              I am sure my machine has the latest updates !!

                              Also can you try downloading the trial of CT 3.11 and see if this is happening.

                              -Avinash


                              • 12. Re: Contribute Connection Disabled.  Help Please!
                                jb5968 Level 1
                                HJ, there are numerous dll download sites available. Google the phrase "windows dll" and pick a free one. I pulled an older version of the dll from a computer with a known working copy of Contribute.

                                Avinash, are you testing it on a SSL enabled network? I have been able to duplicate the issue many times in our environment which is SSL. We are using the registered version 3.11 and since everything is working at the moment, I'd rather not replace it with the trial version.
                                • 13. Re: Contribute Connection Disabled.  Help Please!
                                  mumf
                                  Hi

                                  This has been asked above but not answered what dll file should we download?
                                  • 14. Re: Contribute Connection Disabled.  Help Please!
                                    jb5968 Level 1
                                    See my 8/31/06 post for the full message.

                                    quote:

                                    Originally posted by: jb59
                                    ...The only work-around I have been able to find so far is to replace the c:\windows\system32\wininet.dll file with a version that is compatible with CT3. Version 6.0.2900.2904 is the most recent working version I have found. Rename the old file, replace it with the new one and reboot the computer. I AM NOT recommending that you do this. I am simply stating that this is a viable work-around if you're desperate enough to get Contribute working again. ...


                                    • 15. Re: Contribute Connection Disabled.  Help Please!
                                      mumf Level 1
                                      Sorry but am I missing something, I still dont know what to download to get this problem fixed, what file is it?
                                      • 16. Re: Contribute Connection Disabled.  Help Please!
                                        mumf Level 1
                                        I have finally managed to coonect, I looked at the clients folder on FTP and there was a folder there named _mm deleted that.....and I can now connect!, hoorah!...at last...it has taken me a week to sort this out
                                        • 17. Re: Contribute Connection Disabled.  Help Please!
                                          threemilesdwn
                                          Hello Everyone-
                                          I read through the thread, but have had no luck. What is happening is I am getting that SAME error message, and its only for one specific site. I tried deleting the connection and recreating it. After I put in all the ftp info, and contribute does its thing and then does the ftp diagnostics. I get to the page where it asks for your full name and email address (this is in the my connections window) and after I hit next I immediately get this message. A client was having this problem, and usually what happens on a clients end isn't happening on my end, but this is an exception. Any help would be awesome. Thanks!
                                          • 18. Re: Contribute Connection Disabled.  Help Please!
                                            Level 7
                                            jb59 wrote:
                                            > Raise your hand if you are using Windows XP SP2 and are having this problem.
                                            > I've been fighting this issue since May of this year, and to the best of my
                                            > knowledge, Adobemedia has yet to even acknowledge that there is a problem with
                                            > CT3. It seems that an IE Security Update has hindered the ability of CT3 to
                                            > establish a connection and/or download the content when you try to edit a page.
                                            > Symptoms are: Existing connections suddenly stop working; New connections
                                            > using known good connection keys can't establish a connection; Connections that
                                            > work won't let you edit a page (the program stops responding while downloading
                                            > content).
                                            >
                                            > The only work-around I have been able to find so far is to replace the
                                            > c:\windows\system32\wininet.dll file with a version that is compatible with
                                            > CT3. Version 6.0.2900.2904 is the most recent working version I have found.
                                            > Rename the old file, replace it with the new one and reboot the computer. I AM
                                            > NOT recommending that you do this. I am simply stating that this is a viable
                                            > work-around if you're desperate enough to get Contribute working again. The
                                            > REAL fix is for the software developers to update their application to work
                                            > with Microsoft security updates. http://support.microsoft.com/kb/912812
                                            >
                                            > We are using Contribute 3.11 on a secure intranet using Windows 2003 Server
                                            > with SSL enabled. The problem only ocurs with XP installations, Windows 2000
                                            > users seem to be immune...at least for the time being.
                                            >

                                            Hi,
                                            We are not able to reproduce the issue using SFTP connection against
                                            Windows 2003 Server with SSL enabled and SFTP running on it.
                                            The SFTP server we have used is WinSSHD. Can you please let us know what
                                            SFTP server you have used? And also please let us know your personal
                                            mail id.

                                            -dmichael
                                            • 19. Re: Contribute Connection Disabled.  Help Please!
                                              GECahn
                                              I have 2 websites on Contribute. One works, and the other is suddenly locked out, with an error message about my password being wrong. It's not wrong. I've retyped it, the user name, the web address, ad nauseum and nothing is working, and the site is still disabled. Can someone tell me, written in English please, what to do. Most of what is above is pure gobbledy **** to me. Thanks.

                                              Glenn Cahn
                                              • 20. Re: Contribute Connection Disabled.  Help Please!
                                                GECahn Level 1
                                                I discovered my own answer to the problem of what to do when 1 of the 2 sites I administer refused to accept my password/user name, by asking the web hosting co. They suggested that I instead use the numerical address (e.g. 12.34.56.78) rather than the www.mysite.com version. For whatever reason, that worked.

                                                It sure would be nice if Contribute/Adobe would fix all the damn bugs of this program.
                                                GC