2 Replies Latest reply on Dec 28, 2012 12:23 PM by Donn@1910

    Help with Kobo Glo

    Donn@1910

      I have just got a kobo glo to replace my old sony prs650 and when trying to transfer my books using ade they seem to have worked but when I try to read one on the glo all I get is a blank screen and sometimes it takes me back to the home page. I have authorised my glo with my account and the book is actually in my library on the device so I'm not sure what is wrong. I have installed both ade2.0 and the older version but the same thing is happening with each of them. I'm not terrible with computers but I'm not a total whizz either so any help would be appreciated. Thank you!

        • 1. Re: Help with Kobo Glo
          sjpt Level 4

          I had similar issues with a small number of books on a Bookeen Cybook Opus.

          Are most books are working fine on the glo?

           

          On the Opus, most books work fine; some just won't read or go back to home page as you say;  and trying to read one particular book would reboot the Opus.

          None of them has been books I urgently wanted to read, so I just moved onto the next book ~ not a good general solution.

          My guess (it is only a guess) is that the books are incorrectly formatted, and that some readers are better able to handle the error.

           

          Where the book is not DRM you could probably use Calibre to do a minor conversion on the book, which might correct the formatting errors.

          Alas, if my guess is right I don't see any solution for DRM books.

          • 2. Re: Help with Kobo Glo
            Donn@1910 Level 1

            All the books I had previously downloaded from the Kobo website work fine but none of my others do and I only had about 20 kobo books and about 100 others.

             

            I use Calibre anyway as I hated the Sony Reader, it was slow and always crashing, and I have reformatted a lot of books on there which worked fine on my Sony but dont seem to want to work on the glo. I can connect the glo to Calibre too but I just get the same issue.

             

            Weirdly when I tried to change the font or page view on the glo I would briefly get a view of what was written on the page but then it would go back to blank, I'm so confused!