2 Replies Latest reply on Nov 27, 2007 7:39 PM by mngther

    Contribute could not connect because the server is down"

    JustJamesAus
      My client tries to connect to the website with Contribute and gets the error "Contribute could not connect because the server is down" however I connect with no problems, using Contribute or Dreamweaver.

      I sent him a new connection key but the same error.

      Only problem I ever have is that sometimes I get a "can't save files to shared something-or-other" on exit after administrating, but I don't know if that's related or not - it never seems to affect anything at my end.

      Please help! Thanks
        • 1. Re: Contribute could not connect because the server is down"
          mngther
          Hey JustJames,

          Have you worked out the answer to your problems yet? I am having the same problem and it is driving me up the wall. My client can load the page and edit it but not publish.

          I thought it may have been because I had installed CS3 and my client was on 3. It only happens on sites that I have connected to with CS3.

          Since then I have changed the compatibility mode to transition (said it should have been that by default but ovbviously it wasn't). I have also reissued new connection keys and they don't work.

          Now my client has downloaded and installed the CS3 trial and it still happens.

          I have just tried removing myself as the administrator and they have deleted the connections and recreated them using FTP (not connection keys) and setting themselves as administrator and noe they get an error Access denied. The file does not exist or there could be a permission problem.

          I don't get any errors when editing or publishing pages to these sites.

          I thought it may be a firewall or something else at their end but apparently nothing there has changed.

          If anyone has a solution I would love to know it.

          Thanks.

          I have removed all my administra
          • 2. Re: Contribute could not connect because the server is down"
            mngther Level 1
            OK, problem solved here:

            The access denied or file does not exist error was being caused by the fact there was a 0KB index file somehow.

            Once we got rid of that we still had the "Contribute could not connect because the server is down or not accpeting connections" error to get round.

            I had previously asked my client to go in an change the FTP settings in the Advanced screen to be Choose FTP server settings manually and select Use Passive FTP to connect to the server and make sure Use FTP Performance Optimization is not selected. I don't think this was ever done (and if it had been it would have saved me HOURS of time spent trying to diagnose this problem).

            Today I ended up backing up every contribute related file and folder on the server to my local machine then deleting them. After having done that I asked my client to create a new connection using the FTP details (not a connection key). That still didn't work so I got them to (and this time they did it) change the advanced FTP settings as above and BINGO! they can now publish.

            I'm guessing that if I had sent a connec tion key with the same settings specified in the Advanced FTP then it still would have worked.

            I hope this saves someone else some time. I am going to have a few beers now to celebrate.