6 Replies Latest reply: Jun 18, 2013 12:25 PM by engstromx RSS

    Lightroom 4.3 not importing all photos

    Neil M Beadle

      Using Mac, 10.7.5

       

      Have used lightroom version 3 (now 3.6) with Canon 7d and Canon 5dmk11 with no issues.

       

      Connect cameras to computer via usb, in lightroom 3.6 both cameras immediately recognised by lightroom import preview pics shown, no issues.

       

      Ugraded to lightroom 4 (now 4.3) have no issues importing photos from Canon 5dmkii, however seems to be hit and miss with the 7d. Lightroom does not automatically see the 7d, I have to use import and then select the 7d.  On importing the photos sometimes it is fine other times I have a number of photos with a ? and message missing file cannot be located.  Close down lightroom 4, open lightroom 3.6 connect the 7d and all the photos are imported including the ones that had a ? in LR4.

       

      In the end I stopped using LR 4 went back to LR3, but have recently bought Fuji XE1, raw files not supported in v 3 so back to using LR4, and am getting the same issue. Have deleted and re-installed lightrrom 4 , still some import issues, tried Adode remote chat line, (waste of time, the rep had less idea on LR than I do)

       

       

      Please has anybody got any ideas, as to cause or a solution, as this is driving me up the wall,

       

      Many thanks Neil

        • 1. Re: Lightroom 4.3 not importing all photos
          RikkFlohr Community Member

          I am guessing you are connecting directly via the camera.

           

          Can you/have you tried a card reader and see if you get the same result?

          • 2. Re: Lightroom 4.3 not importing all photos
            Neil M Beadle Community Member

            Rikk,

             

            Thanks for the reply,

            yes I have tried with a card reader and have had some mixed results, but always when I go back to lightroom 3 all the photos are seen and imported.

             

            I reinstalled LR4 yesterday, upgraded to v4.3.

            I have set up a new catalogue with none of my historic photo's, I will archive those in LR 3.6.

            Have re-installed the latest firmware for the canon 7d,

             

            Took some test photo's connected camera via usb, had to manually select import, the 7d was listed, then imported pics, no problem this time, need to see if this is consistent. Did the same with the Fuji xe1 and all 12 pics loaded.

             

            Will try tomorrow with significantly more pictures from both cameras.

             

            I wonder if there is any issue associated with importing the old catalogue from 3.6 and upgrading in LR4?

             

            Enjoy New year,

             

            Neil

            • 3. Re: Lightroom 4.3 not importing all photos
              engstromx

              I too have noticed some oddities using LR4.3 with a Canon 5d MKIII.With the release candidate and prior I had no problems but now I regularly get missing previews before import and also sometimes photos won't import. With the non-importable ones I try again and so far they have imported the second time. I'm going to get a new CF card and try a card-reader instead of direct import from the camera.

              • 4. Re: Lightroom 4.3 not importing all photos
                Geoff the kiwi MVP

                USB cables direct to cameras leading to issues is widely reported. I use a card reader unless it's some kind of emergency and have no issues. use a reputable card reader too!!

                • 5. Re: Lightroom 4.3 not importing all photos
                  Neil M Beadle Community Member

                  Thanks for all the replies,

                  I have used a lexar cf sd card reader if i have had issues with the direct usb link, and I still get issues with photo's being imported with the grey ? but only in lightroom 4.  If I connect the card via camera usb or card reader with LR3.6, then no issues at all , all the photo's are imported, none with the grey?

                  So to my logic, the camera usb link works fine in LR3 for both canon 7d and 5dmkii, as does the card reader.

                  When i have tried to use LR4, the photos on the 5dmkii are always imported with no issue, by camera usb or card reader, but I have variable results with the 7D, (THE 7D HAS LATEST FIRMWARE 2.03).

                   

                  Am I missing something simple in the preference set up, file numbering or labelling?

                   

                  Regards Neil

                  • 6. Re: Lightroom 4.3 not importing all photos
                    engstromx Community Member

                    Resurrecting an old thread; It turned out my problem was the card reader connection...not the one between the card reader and the iMac but the power connection. It turns out that my Belkin 7 USB hub needs to be plugged in directly to the power outlet and not via a 4 bar or whatever. Now I've done that I get no problems whatsoever with my CF imports or my Garmin GPS watch...