5 Replies Latest reply on Sep 12, 2008 6:47 PM by 1114JR

    Flash9 Error 1904 Insoluble Problem

    rhondalea
      Each time I try to install Flash, I receive the following error message:

      Product: Adobe Flash Player 9 ActiveX -- Error 1904.Module C:\WINDOWS\system32\Macromed\Flash\Flash9d.ocx failed to register. HRESULT -2147220473. Contact your support personnel.

      My permissions are exactly as they should be, but I ran subinacl.exe anyway. I have uninstalled and reinstalled countless times--several times with my firewall and virus scanner turned off--and I have also registered the .ocx file manually (successfully, according to the message I received). I have used ERUNT to restore my registry to a date before Flash went wonky (a little more than a week ago).

      I have tried several different installer links. Some of them refuse to work because they say there is a newer version available.

      When I check IE7's add-ons, there is no Active-X control for me to enable.

      I'm at the end of my rope with this, so I hope there will be a fix for it soon.
        • 1. Re: Flash9 Error 1904 Insoluble Problem
          rhondalea Level 1
          Never mind. I found the fix.

          http://labs.adobe.com/technologies/flashplayer9/releasenotes.html#install

          Download the Uninstaller
          Open the Windows Command Prompt ( Run > cmd ).
          Navigate to the directory where the uninstaller was downloaded.
          Run "uninstall_flash_player.exe /clean."

          Do it twice.

          I don't know why the /clean switch makes a difference, but it does. And I don't know why running it twice is required, but it is.
          • 2. Re: Flash9 Error 1904 Insoluble Problem
            OMF(UK)IT
            I am a network administrator on my organisations domain. We recently had the 1904 error on a number but not all our machines after rolling out the flash9 active x msi from Adobe.

            After many fustrating hours of research and testing. I looked at adobe articals about permissions on the Shockwave.Shockwave registry keys and registering flash9.ocx with regsvr32.exe and had very little luck.

            In the end I created .reg file containing certain keys and sub keys (the subkeys is partly what fixed it for me) from a working machine. And copied the full contence from the c:\winodws\system32\macromed\Flash from the working machine to a usb drive.

            I then deleted the contence of the c:\winodws\system32\macromed\Flash on the machine with the error and replace them with the copy I took from the good machine.

            I then ran the .reg file I created.

            This fixed all our machines.

            I have attached a copy of the .reg code below, First backup the registry and then if you copy the text below in to a txt file and then rename it to be .reg, and double click it to load in it into the registry.

            Then if you go to a web page that uses flash such as a youtube video it will all work fine.

            ----- copy these files first from a working machine.
            --Flash9.ocx
            --Flash9f.ocx
            --flash.ocx
            --FlashUtil9f.exe
            --KB913433.inf
            --UninstFl.exe

            ------Here's the reg file

            Windows Registry Editor Version 5.00

            --0

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash]
            @="Shockwave Flash Object"
            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash\CurVer]
            @="ShockwaveFlash.ShockwaveFlash.9"

            --1

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.1]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.1\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --3

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.3]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.3\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --4

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.4]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.4\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --5

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.5]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.5\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --6

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.6]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.6\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --7

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.7]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.7\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            -8

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.8]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.8\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            --9

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.9]
            @="Shockwave Flash Object"

            [HKEY_CLASSES_ROOT\ShockwaveFlash.ShockwaveFlash.9\CLSID]
            @="{D27CDB6E-AE6D-11cf-96B8-444553540000}"

            Regards,


            Jonathan Ford
            • 3. Re: Flash9 Error 1904 Insoluble Problem
              1114JR
              I am having the same error, and have had no luck getting this fixed. I installed IE 8 hoping that would be the solution, but did not work. I am not familiar with dos and how to give permissions. Is there an easier fix out there? I have tried uninstalling/re-installing with no success. Any help would be greatly appreciated.
              • 4. Re: Flash9 Error 1904 Insoluble Problem
                rhondalea Level 1
                I've had no problems with Flash 10.
                • 5. Re: Flash9 Error 1904 Insoluble Problem
                  1114JR Level 1
                  I just tried downloading version 10, but still get the same error, referring me to tn_19166.