5 Replies Latest reply on Nov 26, 2007 3:30 PM by Greg Dove

    getURL mystery

    Bob Pierce Level 1
      Can anyone explain why the following statement works despite the file in question having been updated to PriceList_3.pdf.

      getURL("downloads/PriceList_2.pdf");

      I uploaded the new pdf and deleted the old one but forgot to edit the line above. It worked fine. The correct file was downloaded, not some cached copy of the old one. There are .zip and .sit versions too and they are also downloaded correctly. Is the version digit being ignored somehow?
        • 1. Re: getURL mystery
          kglad Adobe Community Professional & MVP
          the file was pulled from your browser's cache. clear your cache and retest to see the results you expect.
          • 2. Re: getURL mystery
            Bob Pierce Level 1
            Thanks kglad. I did try your suggestion, in both Firefox and IE, but no change. I think you've mis-read the situation. The NEW file is being fetched, despite the .swf referring to the old one.
            • 3. Re: getURL mystery
              kglad Adobe Community Professional & MVP
              something's not as you explain it.

              try to put together a sample fla and pdf that displays the issue.
              • 4. Re: getURL mystery
                Bob Pierce Level 1
                Your scepticism is understandable! The .swf involved is one of many loaded by the site so I've made a cut down version and used it in a new, single page site here.

                The entire code is below. You will see that getURL only calls PriceList_2.***

                The content of the downloads folder is:
                PriceList_3.pdf
                PriceList_3.sit
                PriceList_4.zip - // this is actually PriceList_3.zip but renamed on the server

                On my Windows system at least, in Firefox and IE, all three buttons work, but they download the above files, not the one called. Apart from the borrowed and stripped down .fla this is an entirely new site created for this test. I couldn't reproduce the behaviour initially because I placed the downloads in the same folder as the .html and .swf, but when I move them to /downloads it "worked"!

                I'm guessing this isn't a Flash thing, perhaps a Linux peculiarity? On my testing server, IIS, this site throws an error.

                Bob

                • 5. Re: getURL mystery
                  Greg Dove Level 4
                  Whatever it is that's happening its external to flash

                  Your server returns a HTTP response for the pricelist_2 request saying HTTP/1.1 301 Moved Permanently
                  and redirects to:
                  Location: http://www.test.bobpierce.eu/downloads/PriceList_3.pdf

                  So this will happen in the browser as well.

                  Click this link and you will see the same thing in the address bar:
                  http://www.test.bobpierce.eu/downloads/PriceList_2.pdf