2 Replies Latest reply on Jan 9, 2013 5:02 PM by Artemis17au

    Can't change fonts

    Artemis17au

      Before Christmas I received an ID file from a typesetter who forgot to package their fonts, which was no problem as I changed the fonts to another similar one.

       

      Post-Christmas holidays I came in and found two system updates on my Mac. Waited for that to install and then opened the ID file. To my horror, 406 Missing font errors came up. I managed to fix 400 of them easily enough, but the remaining 6 are causing huge problems. They keep saying they were the fonts originally used by the typesetter, which of course means they're 'missing', and no attempts by me to manually change them to the new fonts has worked. If I attempt a complete style change, ID freezes and I have to force a quit. If I try to retype the whole thing and reformat them without any style that only gets me so far - the moment I try to delete the text showing up in the orange highlight, ID freezes and I have to quit. Similarly copying other text in that style I want works until I try to paste over the orange highlighted text, freeze and quit.

       

      At first I thought it was the updates I did to the system - I lost connectivity to networks for a while there - but have since fixed that. I also updated my entire Adobe suite and that hasn't done anything either. Any ideas?

        • 1. Re: Can't change fonts
          Eugene Tyson Adobe Community Professional & MVP

          Give this a try http://forums.adobe.com/thread/526991

           

           

          Also, are you using any font management systems, what fonts are reported missing that you can't change, any other info?

           

           

          Have you tried creating an new document with identical Document Setup, margins and bleeds, and then use the Pages Panel sub menu to "Move Pages" and select the new document as the destination.


          When you do this can you change the font?

          • 2. Re: Can't change fonts
            Artemis17au Level 1

            Hi Eugene

             

            I tried to export it as an IDML and it crashes. This isn't my computer so I'm not sure about the font management system, I'm learning InDesign on the fly so to speak.

             

            The 'missing' fonts are: Clarendon BT Heavy and Minion Pro Heavy. They should be Minion Pro Regular, which is what our designer changed it to before she left (I fibbed a bit in the original question to simplify the matter, but now I see it's much more complex then I thought).

             

            So I tried to trash the preferences, but nothing happened, although with that particular exercise I'm not 100% sure I'm doing it right. As it's not my computer I don't feel right just deleting the files, so I moved them and nothing happened.

             

            Also now when I try to change the fonts (with or without the old preferences), all of the type around it changes to Batang Regular and I can't change it back. I have no idea why, possibly this is also what the typesetter originally used?

             

            The whole document is 200 pages long, so I'm a bit loath to restart the whole process, but it might have to happen... that said if the font is the problem, copying the text would only make it carry across right?

             

            Thanks for the advise!