3 Replies Latest reply on Jan 10, 2013 10:15 AM by cardeo77

    Added component not to be seen in sidekick

    u005078

      Being new to WCM I tried to add a component as described in "First Steps for Developers". But I can't see the new component neither in sidekick nor in "Insert New Component"-Dialog. What I exactly did, was

       

      1. created node "MyProject", primaryType=nt:folder to /apps

      2. created node "components", primaryType=nt:folder to /apps

      3. copied: /libs/foundation/components/text to /apps/MyProject/components/text

      4. renamed /apps/MyProject/components/text to /apps/MyProject/components/MyComponent

      5. changed Property jcr:title from "text" to "MyComponent" for node /apps/MyProject/components/MyComponent

      6. renamed /apps/MyProject/components/MyComponent/text.jsp to /apps/MyProject/components/MyComponent/MyComponent.jsp

      7. save all

      8. added String "/apps/MyProject/components/MyComponent" to Property "components" in node /etc/designs/geometrixx/jcr:content/contentpage/par

      9. save all

       

      Then I called the "Children's"-Page,  which I had created according to the description in "First Steps for Authors". But the componennd doesn't show as described in the beginning of this thread.

       

      What's wrong with my actions? I'm pretty sure that I exactly worked according to the sample.

       

      brgds,

      Ulrich