0 Replies Latest reply on Jan 11, 2013 3:32 PM by czigany

    List control issue in Projector mode after Printomatic

    czigany Level 1

      I'm working on an application in MX. I'm using a multi-select list control and mostly it's working fine. However, in Projector mode, under certain circumstances, my list is shown considerably reduced in size and, when I click on it, I get a Director player error: Property not found #selectedIndex.

       

      I've narrowed the problem down to the use of Printomatic. Unfortunately I'm stuck with Printomatic for the time being.

       

      I've tried changing the list to a single-select with no change. I've put an alert when I click on the list to determine whether the list object is receiving messages and it is. I've tried returning from the Printomatic calls to a frame where the list doesn't already exist and then recreating the list - no change.

       

      It seems as though Printomatic is corrupting something related to the list. And, once it's been corrupted, it stays corrupted until I restart the executable.

       

      Anyone have any suggestions? I don't have time right now to implement a printing class which is the only other idea I have.