5 Replies Latest reply on Feb 12, 2013 11:28 AM by Mark_Rausch

    Localhost not working

    HedonisticOne

      Hey,

       

      I'm running edge inspect and can view pages online perfect. But my localhost is not working.

      the pages displays an error 'Web page not available'.

       

      I am using WAMP and  I am thinking it may have something to do with the apache settings, possibly it's only binding the the localhost? (I can't connect to the localhost from the device by tryping in the ip address and the path).

       

      anyone got any ideas on how to fix this?

        • 1. Re: Localhost not working
          HedonisticOne Level 1

          Ok after further playing around, I have now added it to the firewall in windows and can now see it. But the localhost is Forbidden.

           

          This is the same as if I change localhost to the ip address on the actual computer. So Now I'm pretty certian it's a wamp thing.

          1 person found this helpful
          • 2. Re: Localhost not working
            HedonisticOne Level 1

            Ok figured it out.

             

            For anyone in the future that has this problem:

             

            In wamp open your httpd.conf file.

            Find the line that says <Directory "c:/wamp/www"> (Note your path may be different depending on your localhost path.)

             

            A few lines below this you will see these lines:

            Order Deny,Allow

            Deny from all

            Allow from 127.0.0.1

             

            Change Deny from all to Allow from All

            and comment out (#) the Allow from 127.0.0.1 line

             

             

            Cheers!

            • 3. Re: Localhost not working
              mrjoz Level 1

              ok so thanks for the help, though this wasn't crystal clear to me as there were two instances of that three line block. Here's is a cut and paste of the Altered block with a little extra cut from the surrounding area just to be sure you are addressing the right instance

               

              AllowOverride all

                  #

                  # Controls who can get stuff from this server.

                  #

               

              #   onlineoffline tag - don't remove

                  Order Deny,Allow

                  Deny from all

                  Allow from all

               

              </Directory>

               

               

              #

              # DirectoryIndex: sets the file that Apache will serve if a directory

              # is requested.

              #

              <IfModule dir_module>

                  DirectoryIndex index.php index.php3 index.html index.htm

              </IfModule>

               

              the bold line is the line I changed to get things working. it use to read Allow from 127.0.0.1

               

              Lastly, the file location is going to be a veriation of what H1 suggested....or so i thought. my httpd.conf file was actually found here [drive]:\wamp\bin\apache\apache2.2.22\conf

               

               

              Thanks once again for the help though, i would have never got this far without the help

              • 4. Re: Localhost not working
                bikeman01 Level 1

                I'm using Xampp. Adding allow from all to my httpd.conf has no effect. Anyone? Thanks

                • 5. Re: Localhost not working
                  Mark_Rausch Adobe Employee

                  bikeman01, are you sure you've modified the #onlineoffline tag section of the configuration file?

                   

                  Have you turned off your software firewall completely on your computer?