6 Replies Latest reply on Jun 15, 2013 7:58 PM by mildred_ignacio

    Author intallation issue

    Shawx

      Hi,

       

      Could anyone please help me on this?  The environment is Linux.  I followed the instruction to install the author instance in a new port number 8081 by use this command "java -XX:MaxPermSize=256m -Xmx1024M -jar CQ_author-p8081.jar", at the end, it shows "Press CTRL-C to shutdown the Quickstart server..." without error.  I assume that the CQ Quickstart is working.

       

      Then I ran the ./start from the bin directory.  it shows these message:

      17.01.2013 13:50:58.578 *INFO * [main] Starting launcher ...

      17.01.2013 13:50:58.580 *INFO* [main] HTTP server port: 4502

      17.01.2013 13:51:09.469 *INFO * [main] Startup completed

       

      I assume that CQ is up, but the port is 4502, does it have to be 8081 which is same as quickstart?

       

      At the end, I did not see any web browser opened like the instructions said "When the installation is completed, you are automatically presented with a new web browser window opening http://localhost:4502/".

       

      Did I miss anything?

       

      Thanks.

        • 1. Re: Author intallation issue
          Scott Brodersen Adobe Employee

          4502 is the port that is configured in the start file.

           

          If you open the bin/quickstart file in a text editor, you will see where you can specify the port and jvm properties to use. If you want to use port 8081, edit this file and then use this file to start the server. Also, this file is configured so that the admin page opens in the browser when the server is up.

           

          hope that helps

          scott

          1 person found this helpful
          • 2. Re: Author intallation issue
            Shawx Level 1

            Scott,

             

            Thank you for your help.  I was able to change the port number in both start and quickstart.  I noticed that the admin page opens is "#CQ_NOBROWSER='true'".  But the browser is not open up after I started the both quickstart and CQ server.  I noticed that there are some error message in the error log.  It is related to cluster.  I am not setting cluster, I am not sure if it will affect the CQ.  The cluster related message are these:

            17.01.2013 15:10:02.885 *ERROR* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl failed to start Repository: Unable to register data store in cluster. javax.jcr.RepositoryException: Unable to register data store in cluster.

            Caused by: java.net.UnknownHostException: xxxxx: xxxxx

            at java.net.InetAddress.getLocalHost(InetAddress.java:1426)

                at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:191)

                at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:180)

                at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:384)

                at java.net.Socket.connect(Socket.java:546)

                at java.net.Socket.connect(Socket.java:495)

                at java.net.Socket.<init>(Socket.java:392)

                at java.net.Socket.<init>(Socket.java:235)

                at com.day.crx.core.cluster.ClusterMaster$3.execute(ClusterMaster.java:385)

                at com.day.crx.core.cluster.ClusterController.attempt(ClusterController.java:1385)

                at com.day.crx.core.cluster.ClusterMaster.listen(ClusterMaster.java:383)

                at com.day.crx.core.cluster.ClusterMaster.startListener(ClusterMaster.java:196)

                at com.day.crx.core.cluster.ClusterController.startMasterListener(ClusterController.java:840 )

                at com.day.crx.core.cluster.ClusterController.start(ClusterController.java:684)

                at com.day.crx.core.cluster.ClusterController.register(ClusterController.java:919)

                at com.day.crx.core.data.ClusterDataStoreSkeleton.init(ClusterDataStoreSkeleton.java:94)

                at com.day.crx.core.data.ClusterDataStore.init(ClusterDataStore.java:177)

                ... 56 more

            17.01.2013 15:10:02.887 *INFO* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl Shutting down repository...

            17.01.2013 15:10:02.892 *INFO* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl Repository has been shutdown

            17.01.2013 15:10:02.910 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] The activate method has thrown an exception (javax.jcr.RepositoryException: Unable to register data store in cluster.) javax.jcr.RepositoryException: Unable to register data store in cluster.

            • 4. Re: Author intallation issue
              Shawx Level 1

              Scott/Jorg,

               

              Thank you for your help.  The issue is resolved.

              • 5. Re: Author intallation issue
                KishCq5@@ Level 1

                Hi All,

                 

                I am also facing the issue where i am running publisher author is starting in up.

                 

                I am doing an CQ5.6 installation in linux. the steps which i folled is below

                 

                1> i created an folder author and copied the quickstart.jar and licence porperties into it

                2) i renamed the file to aem5.6-author-p4502.jar and unpacked it using java -jar aem5.6-author-p4502.jar -unpack

                3)once it got unpacked succesfully i went inside /crx-quickstart/bin and ran ./start . the CQ author instance ran succesfully and i am able to see the login page on browser

                4) next i created one publish folder and inside it i copied the jar and licence properties.

                5)after that i renamed the jar to aem5.6-publish-p4503.jar and unpacked it and went inside /crx-quickstart/bin and started the publish server  by ./start

                 

                interestingly publisher  started running on port 4502 and when i check the browser http://localhost:4503/ dosent come up only author is running. I am doing this in Red Hat Linux and I am using AEM 5.6.

                 

                Please let me know if i am missing something.

                • 6. Re: Author intallation issue
                  mildred_ignacio Level 1

                  may you check: ps -ef |grep java if the publisher is running?

                  also check error.log, stdout.log and log under logs/crx and server/logs to see if any issue. e.g. port is in use. try to run: netstat -an | grep 4503

                  to check also if there is listening on port 4503

                  paste the error you see in this forum for us to check.

                  i wonder why you say it starts with 4502. you rename the jar right? seems the port 4502 running is author. you can see on ps -ef | grep java and also when view the page if it is author or publisher.

                  thanks!