0 Replies Latest reply: Jan 18, 2013 10:20 AM by ColoradoFlash22 RSS

    Bus Error: 10 while packaging a Flash Builder 4.6 application containing a native extension (ANE)

    ColoradoFlash22 Community Member

      I get this error:


      ld: warning: -ios_version_min not specificed, assuming 4.0

      ld: warning: -dead_strip with lazy loaded static (library) archives has resulted in a duplicate symbol.  You can change your source code to rename symbols to avoid the collision.  This will be an error in a future linker.

      /var/folders/y4/svqv7kzn469_ljcrvw1b99500000gn/T/cmd8085539752601990184.tmp: line 2: 25159 Bus error: 10           "/Applications/Adobe Flash Builder 4.6/sdks/4.6.0/lib/aot/bin/ld64/i686-apple-darwin10-ld64" -ObjC -dead_strip -Z -arch armv7 -syslibroot "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iP honeOS6.0.sdk" -L/usr/lib -F"/System/Library/Frameworks/" -L"/Applications/Adobe Flash Builder 4.6/sdks/4.6.0/lib/aot/lib" -o "../aot8213014594451590298.tmp" -L"/var/folders/y4/svqv7kzn469_ljcrvw1b99500000gn/T/07f32573-0d2b-42c6-b431-916954d76791" -exported_symbol _main -exported_symbol _ExtInitializer -exported_symbol _ExtFinalizer "extensionglue.o" -lstdc++ -lRuntimeInterpreter.arm-air -lgcc_s.1 -lstdc++.6 -lcrt1.o -lSystem.B -lz -lobjc -framework CoreFoundation -framework UIKit -framework MobileCoreServices -framework CoreGraphics -framework Foundation -framework SystemConfiguration -framework AudioToolbox -framework CFNetwork -framework QuartzCore -framework OpenGLES -framework CoreLocation -framework CoreMedia -framework CoreVideo -framework AVFoundation -framework Security -lcom.pgi.native.extensions.softphone

      Compilation failed while executing : ld64



      The ane was created using this command:


      "/Applications/Adobe Flash Builder 4.6/sdks/4.6.0/bin/adt" -package -target ane SPExtension.ane extension.xml -swc SPTest.swc -platform iPhone-ARM -C ios . -platformoptions platform.xml


      The ANE file seemed to load in my project ok, and build ok.  But when I hit run to package for my ios device, I get the above error.