3 Replies Latest reply on Jan 21, 2013 1:35 PM by NirMizrahi

    Movie not loaded

    NirMizrahi

      Hi

       

      I have a problem with hosting a .swf file.

      I used to have a CS5.5 version of it which worked fine.
      I recently compiled a flash project with Flash Pro CS6, and since then when I try to load it in my website it gives me a blank screen with that "Movie not loaded" problem.
      When I open it locally it works.
      When I open it in the browser with the HTML wrapper it works.
      When I drag and drop it to the browser it works.

      But when I try to access it from my site it doesn't.

       

      I tried to delete my cache, cookies related to the site, compile it as debug version, go to the Flash player settings advanced tab and "delete all...".

      Nothing worked.

       

      I use Apache 2.2 if it matters.

       

      If you need anymore info to troubleshoot this problem please let me know.

       

      Help will be appreciated.

        • 1. Re: Movie not loaded
          moccamaximum Level 5

          Look for classes that got an update between 5.5/6 or were moved to different packages.

          If your main.as was compiled with flash CS5.5 and the loaded one with 6,

          if there are conflicting class definitions, the parent`s one will be used, thus causing the loaded one not to function as expected.

          Details here

          • 2. Re: Movie not loaded
            Ned Murphy Adobe Community Professional & MVP

            Provide a link to the online implementation so that file locations versus html pathing can be checked.

            • 3. Re: Movie not loaded
              NirMizrahi Level 1

              Ok I fixed it.
              It was a problem with the Apache server.
              I restricted access to subfolders, and it seems that it blocked the new .swf for some reason.

               

              I fixed it like this (httpd-vhosts.conf):

              <Directory path>

                   AllowOverride AuthConfig Indexes

                   Order deny,allow

                   Deny from all

                   Allow from 127.0.0.1

                   <Files "*.swf">

                        Allow from all

                              </Files>

              </Directory>


              Though it's weird it only happened after I switched to the new file, because I didn't have to do this with the old build.
              Any idea why it happens?