3 Replies Latest reply on Jan 22, 2013 3:11 PM by Sham HC

    Web Font Files Corrupted

    jeffreywpearson@gmail.com

      I am using CQ 5.5. A customer site that I have the task of bringing into CQ included the use webfonts from Font Squirrel. Usually I deploy through Maven and noticed when I checked the site with Firefox, the fonts are not being used and Firefox is displaying eerrors:

       

      [17:22:52.177] downloadable font: incorrect file size in WOFF header (font-family: "simplesans bold" style:normal weight:normal stretch:normal src index:1)

      source: http://localhost:4502/etc/designs/projectname/fonts/simplesans-bold-webfont-webfont.woff @ http://localhost:4502/etc/designs/projectname/static.css

       

      It is displaying this error for every one of the 'special fonts' used. From the error, it appeared the font file was corrupted. So I copied them again from source into the project. No go. Then I tried copying them directly into my /etc/designs/projectname/fonts. I see them intially added at the right size but then almost immediately jump up to about double the original size. Obviously CQ, is processing them in some way that is corrupting them.

       

      Has anyone seen this and can provide guidance?

       

      Any suggestions are greatly appreciated.

       

       

      Jeffrey W. Pearson

        • 1. Re: Web Font Files Corrupted
          Sham HC Level 7

          Hi Jeffrey W. Pearson,

           

          I doubt it would be releated to CQ.  Only suspect I could thing is there is another CSS file with in your project which is overwriting the font family. Please verify all the css.

           

          Thanks,

          Sham

          • 2. Re: Web Font Files Corrupted
            jeffreywpearson@gmail.com Level 1

            Sham,

             

            Thanks for the reply.

             

            I spent so much time on this because I was leaving cq as being the suspect as a last resort. However, the steps I took by copying them via webdav pretty much confirmed that cq is modifying the files after upload by my own eyes seeing the file sizes jump up after upload..

             

            An extra tidbit I have discovered is that by uploading them into the dam, the files were not changed. I could then change the path in my css to the files within the dam and everything worked perfectly.

            • 3. Re: Web Font Files Corrupted
              Sham HC Level 7

              Thanks for update and glad to hear you could come up with workaround.

               

              Though issue seems strange to me. Just to reconfirm uploading the file using webdav at /etc/designs/projectname/fonts  increasing the size ? If so is it happening for any files types or a specific file types.