12 Replies Latest reply on Jun 23, 2009 3:39 PM by TechWriterKat2

    My copy of RH7 has gone goofy...

    Kathy313
      Hi everyone--
      I had been using a trial copy of RH7, and it had been working FINE. I bought a license, then when I entered my new serial number, it started misbehaving. Two things I have found so far are as follows:

      (1) A newly created project will not open. In RH7 I created a new HTML Help project. I saw the status messages as new files were generated, but when it got to the point of actually opening the project, RH7 hung. The title bar went "Not Responding" and I had to kill the program. All files appear to have been created. Subsequent attempts to open this project repeat this behavior i.e. RH hanging and going Not Responding.

      However... while still in trial mode (before I got my serial number), creating a new project worked perfectly. Also, after entering the serial number, I went back to that same project to keep working, and it opened just fine. The problem area seems to be only that a project newly created after entering a serial number cannot open.

      (2) Cannot insert an image using the Insert Image dialog. I click the Insert Image icon, follow the dialog to navigate and select the image, click OK and go back to the Insert Image dialog -- there IS NO image selected, and "(No preview)" shows in the image preview area.

      I tried this several times, in different topics and with different images. I can manually enter the IMG tag just fine in the HTML code. Also, if the image has already been used elsewhere in the project, I can successfully select it from the "Images in Project Folders" nav tree. What seems to be broken is selecting an image from the Browse button next to the Image name field at the top of the dialog.

      Questions:
      Have these issues been seen by anyone else, either in a fresh copy of RH7 or a trial version that got a serial number?
      I checked for patches; found none.
      I have not yet tried uninstalling, then reinstalling the download file I got with my purchase (corporate purchasing obtained a fresh copy of the software) - but will do so after checking for replies here.
      My PC has Windows XP SP2, if that matters.

      Thanks for any tips or insight...
      ~Kathy.
        • 1. Re: My copy of RH7 has gone goofy...
          RoboColum(n) Level 5
          Hi Kathy. This has come up in the past and Adobe have recommended deleting the licence key for the trial although this link recommends you don't. I'd recommend contacting Adobe Support before doing anything.
          • 2. Re: My copy of RH7 has gone goofy...
            Peter Grainge Adobe Community Professional (Moderator)
            Although that article has been updated this year since new licensing was introduced in RH6, I too would be very wary of deleting the trial licence key without specific confirmation from Adobe. The trial for RH7 is very different to any previous trial and the topic has not been updated for that.

            I agree with Colum that you should contact Adobe first.

            I am wondering if you installed the trial without uninstalling RH6 and then purchased an upgrade rather than a full licence. That would likely cause problems.

            • 3. Re: My copy of RH7 has gone goofy...
              Kathy313 Level 1
              A license key for the trial? I don't recall getting one. Never needed to enter one either, as the splash screen gave 2 radio buttons: one to enter a serial number and one to "try the product".

              RH6? Never had it. I have RH X5. Which I did not uninstall prior to installing the RH7 trial, nor prior to entering my RH7 serial number. Both versions had been coexisting peacefully and fully functioning. Which is good because, not all the other writers in my department are moving to RH7. We are all officially on X5, so I need to retain that for use on other projects. And I have only 1 PC.

              What I ordered-- Our software orders go through a corporate license program (CLP). The way that works is, I fill out a corporate form (my company's, not an Adobe form), send it on up the approval chain, someone else orders it and tracks the license, and the software gets sent to me. Although I asked for the upgrade version (on CD-ROM; I prefer my physical media) on my request form, what I got instead was a download file (from my corporate contact) and an email from Adobe Licensing to retrieve my serial number online.

              The resulting purchase price tells me that corporate did order the upgrade version. However, the file name and file size of what corporate got to download (allegedly the legal purchased version) was the same as my trial version download file -- AdobeRobohelp7_WWEFGJ.exe and 424.3 MB. That tells me it's really not a different copy at all.

              I did not install this file, kind of suspicious of it. I had only opened the RH7 trial, and entered the newly acquired serial number. (Which, the splash screen said is all you need to do.)

              I did tell my corporate purchasing contact that I'm having a problem. Turns out they did order a copy of the CD media "for the keeper of the server" which is in a data center in another state!! I asked if they can send that media to me instead. I really would like a fresh install from the "real thing".

              Ok... I'll contact Adobe support, and reference this message thread, so I don't have to type the details twice! Thanks for the suggestions.
              ~Kathy.
              • 4. Re: My copy of RH7 has gone goofy...
                Peter Grainge Adobe Community Professional (Moderator)
                I have a feeling the download is the same, full or upgrade version. What determines which is the key. Because your key is an upgrade, you are not entitled to keep RH X5. The fact that you have kept both on your PC is likely the cause of your problem. Adobe should be able to confirm or deny that.
                • 5. Re: My copy of RH7 has gone goofy...
                  Kathy313 Level 1
                  You are right Peter, using an upgrade is supposed to ;) preclude the use of the previous version. But if that's whats going on here, you'd think the code would handle that a little bit more explicitly (i.e. like when RH is launched...??), don't you think, rather than dropping out functions that can be worked around!!

                  Yep, workarounds.
                  How I worked around the RH freezing up-- I made a copy of an existing small help system that RH7 *can* open (I had created it while in trial mode), then modified it as needed. How I worked around the Insert Image dialog issue-- manually typed in the IMG tag, then went back to the WYSIWYG and accessed the Image Properties to fine-tune the properties.

                  Well, next week I'll check up on the support case I opened... Talk to you next week, it's a 4-day weekend here for Thanksgiving.
                  • 6. Re: My copy of RH7 has gone goofy...
                    Kathy313 Level 1
                    New developments since my last post...

                    I received what appears to be an auto-responder reply from Adobe tech support that began with "I understand that you would like to reinstall RoboHelp 7 on your machine." (Um, no, that's not the problem!!) The reply did go on to suggest uninstalling all versions of RH and referred to a knowledgebase article http://www.adobe.com/go/kb402654 on RH errors and freezes.

                    I also received a new and different set of RH7 files from my corporate purchasing for me to install from. The files/folders appear similar to content and structure of previous version RH CD's I have.

                    Since I've had no direct answer to the question "why would entering a serial number cause functionality in a trial copy to break (since it wasn't a co-existence issue in trial mode)", all signs are pretty much pointing me towards uninstalling RH7 and reinstalling it. For now I'm leaving my RH X5 installed, as I need it for all the work I do other than these 2 help files to be translated.

                    Not sure if I'll do this today, but I will be back here to report on the outcome.
                    • 7. Re: My copy of RH7 has gone goofy...
                      Kathy313 Level 1
                      Testing results.
                      Oh boy, where to begin.... I do think I've found a bug or two, actually, in the problems I've reported here.

                      Before I started testing, I uninstalled RH7, uninstalled X5 (making sure I had a copy saved of the v502 update!), and cleaned up anything robo I could find in the registry. (The support case I opened told me what registry items to clean up.) Then installed RH7 again from the newer version of the install files supplied to me by my corporate software contact.

                      The "create new project and RH goes Not Responding" problem.
                      I can create this at will, or avoid it at will. Either in trial mode or with the serial number entered. The difference is whether I create the new project on my C: drive or on a mapped server drive. (A departmental policy is that we don't do work on our C: drive, all "official" copies of project work is stored on our server, which is backed up regularly... So at the time I first posted, I hadn't tried C:.) Wondering if the filepath might be a problem, I tried short folder names, long folder names, 7 levels of nested subfolders, spaces or no spaces in the folder names, 100+characters total for the filepath, etc... on both C: and mapped drives. And consistently I found that I can always create a new project just fine on the C: drive, but when creating to a mapped drive RH hangs.

                      When RH does hang in this case, I noticed that only 46 files are getting created, not the usual 49. The missing ones are:
                      -- Flash Help Pro.ssl
                      -- Flash Help.ssl
                      -- Microsoft HTML Help.ssl

                      So that sums up that issue. It's not exactly an acceptable problem (and X5 didn't do this), but it can be worked around by creating a project on C: then copying it over to a mapped drive to continue working.

                      The "browse to select image file not retaining file name" issue.
                      This one is weird. Originally it seemed that the problem was specific to certain files. I don't know what made those particular images any different from the other couple dozen I'd been playing with, other than they are screen captures all created on a certain date, on another PC, by another writer. Oh, and their file names are the longest of all my images.

                      But.. long file names? That gave me an idea. I copied the files and gave them shorter names, and then the problem went away. Hmm. I started moving my test projects around to different locations. C drive or mapped drive on a server. Short vs. long folder name locations, nested levels of subfolders or not -- And it turns out that there seems to be a maximum number of characters in the physical filepath to the image plus the image's file name itself where the Select Image File dialog poops out. 120 characters, to be exact.

                      No matter that the IMG tag is a relative reference to where the topic file is... Apparently, however the Select Image dialog is coded, it must be using a physical reference when navigating to find a file. And if the filepath + image file name exceeds 120 characters, it can't bring back the file name to the Insert Image dialog.
                      I don't know if this is a bug or an intended feature (after all, 120 characters is quite long!!)... but it certainly can affect the portability of a project.

                      So that sums up the "insert image" issue.

                      Also~
                      While going back and forth between projects on C: drive locations and mapped drive locations, I noticed that the Insert Image dialog does not always give you the "right" project directory at first. Rather, it remembers the location of the last image you added, even if that was in a different project and even if RH had been closed since the last time you added an image. RH X5 is still off my pc so at the moment I can't check to see if this was prior behavior as well. So I have to remember to always pull down the "Look in" dropdown (in the Select Image File dialog) to verify where my dialog is 'pointing to' before I select an image to add.

                      Hope these posts have been an interesting read, and if anyone else does see these same problems or wants to test them out for yourself, I'd like to hear from you!
                      • 8. Re: My copy of RH7 has gone goofy...
                        Peter Grainge Adobe Community Professional (Moderator)
                        I have only part read this but can confirm working locally is important. You MUST work locally. See the topic about Installing where I expand on how to do that and keep your IT people happy.

                        If you work on a network, you will have problems.

                        • 9. My copy of RH7 has gone goofy...
                          Kathy313 Level 1
                          Got a followup message today from Adobe on my support case:
                          "In editing projects, we always recommend that you modify the project locally unless you are using Version Control Software. This is the best practice for there are known issues when editing projects from a mapped drive.
                          Regarding the #Select Image File# dialog, I was able to reproduce the issue on my end. I verified this within the application and it only allows up to 65 characters for the filename.
                          You mentioned in your last email that you couldn't create a new project using the new version. If that is the issue and it's happening to all the projects that you try to open, then you need to reinstall RoboHelp following the steps I sent last time."


                          We certainly install the software locally (on our own desktop PCs) but store the projects on a common server. We've been using RoboHelp since almost Day1 (the first version we ever had was BS's WinHelp Office95), have had pretty much every upgrade since (except 1, I think), got training along the way from some of the best (Cheri Zubak, Joe Welinske) -- and honestly this is the first time I have ever experienced problems with a mapped drive or been advised not to have projects on a server.

                          Times change I guess, along with our software and practices. I'll roll with it...
                          • 10. Re: My copy of RH7 has gone goofy...
                            Peter Grainge Adobe Community Professional (Moderator)
                            Often people with your experience come back arguing "I've run off a network since Adam was a boy, it cannot be that". But as you've found my analogy with Russian roulette holds good. Pull the trigger once and it's OK, twice is more risky but might still be OK, eventually though...

                            You might want to think about backing up the projects if they are going local rather than via source control. I use SyncBack which costs around £10. Lock the PC at night but leave it on. It zips and backs up all my projects automatically every night.

                            • 11. Re: My copy of RH7 has gone goofy...
                              Captiv8r Adobe Community Professional & MVP
                              But I've played Russian Roulette for yea(BANG!)......__________________________________
                              • 12. Re: My copy of RH7 has gone goofy...
                                TechWriterKat2

                                Hi, my copy of RH7 has gone goofy too.

                                 

                                I know this an ancient post, but I wanted to add to it because after about 20 minutes of searching through the forums I finally found an answer to the Insert Image problem in your post, so thank you!  I have 2 existing help systems which I just put into Version control (integrating with Microsoft SOS).  SOS expects the files to be in a location on my C drive that is several sub-directories deep.

                                 

                                When I created a new help system in that same directory, Insert Image made me navigate all the way down to the images directory and then lost the file(no preview of it either).  Also, the Insert Images dialog kept dumping me into "My RoboHelp Projects" directory under My Documents and looking for images there. I've never seen that before.

                                 

                                I had to manually cut and paste the file name and its directory hierarchy into the Insert Image dialog.  Then, when I checked the HTML page, it showed up w/ parent directories when what I really want is relative directories.  Anyway, I now keep my new and working copies on my C: drive so I can insert image files again! When it's time to check into SOS, I'll move 'em over, I guess.  So much for checking in works in progress!