3 Replies Latest reply on Jan 25, 2013 1:18 AM by Luigi (8 BIT PLATOON)

    UserManagerLookupService findGroupMembers restricted to 200?

    Luigi (8 BIT PLATOON)

      Hi All,

       

      I have a hopefully simple question.

       

      Scenario:
      1) I have LCES3 connected & synchronizing to the clients MS AD nightly. (Enterprise Domain setup in the LC Adminui)
      2) I need to periodically query a specific group and do something with each user.
      3) The specific group contains 975 users
      4) Im using the Find Group & findGroupMembers operations from the UserManagerLookupService to retrieve a list of users.

       

      Problem:
      1) The findGroupMembers operation is only returning 200 users.

       

      What I have tried / Noted:
      1) Modifying the offset & resultSize values of the findGroupMembers operation to try get the next “batch” of users – no luck.
      2) I opened the GROUP in LC AdminUI and noted that there are only 200 users in the GROUP – I resynchronized
      2 a) Then in LC AdminUI, I went to “Edit Enterprise Domain” -> Directory -> Directory Group. I clicked TEST and saw the GROUP. I clicked on the GROUP, and noted in the “member” Attributes Names in the Attribute Value it listed all 975 users.
      3) I have resynchronzied the Enteprise domain multiple times, but still no reflection (all users showing in the group in AdminUI or via Workbench findGroupMembers query).
      4) The users that need to be in the group, however are showing in the LC AdminUI as users, however in the user’s user groups, it shows that it is not associated with that group.

      5) Googling - on one of the adobe blogs, it speaks about a config file - but doesn't say where it is? (http://blogs.adobe.com/apugalia/lifecycle-of-livecycle-domain-synchronization/)

       

      Question:
      1) Why does LC AdminUI findGroupMemmbers not return the full set of users in a group in a synchronized Enterprise domain (it limits it to 200)?

       

       

      Im hoping this is a simple adminui update, setting or config file change.

       

      Thanking you all in advance