1 Reply Latest reply on Jan 28, 2013 1:02 PM by drsqueegee

    edge files being corrupted in publishing

    drsqueegee Level 1

      I am having a problem with edge corrupting a particular symbol when the publish feature is used. If I upload my files directly from where edge normally saves the files to, everything functions as expected, but if I use the publish feature there is a particular symbol that is not being copied correctly.

       

      I have uploaded a properly working copy of the test site here, and the "published version" here.

       

      The project files for the working version are here, and the corrupted published files are here.

       

      What is supposed to happen is that when the keyboard icon is clicked on it will open a control panel that will then give one an opportunity to choose one of 9 ages and then one of 20 jubilee cycles within each age. Only ten cycles are able to be displayed at one time. This is because I have tried to design the site so that it is functional and clickable on an iPad or even a smartphone. I order to select cycles 11-20 one has to click on the arrow keys, which will alternately reveal the other cycles. It is this particular symbol that is not funtioning properly in the published version.

       

      The symbol name is jub_slider. It is a child symbol of "controlPanel", which is a symbol on the main stage.

       

      I can work arround this for now by not using the publish feature of edge, but eventually I want to use the edge suite plug-in to upload the files to a wordpress site. To use the plug-in I have to use the publish feature to generate the oam file.

       

      The publish feature works fine on everything else except the jub_slider symbol, so there must be something wrong with it that I am not seeing. Perhaps one of the edge experts can see the problem.

       

      Thanks!

        • 1. Re: edge files being corrupted in publishing
          drsqueegee Level 1

          I've just seen a reply from Joe Bowden that states this glitch will be fixed in the next edge release. It's strange how just this one symbol is being effected.

           

          There is another issue which I have been dealing with for some time now, and I don't know if there is a fix for this. It may be that edge was not designed to deal with so much at once, but here is the problem...

           

          I have a group of elements that are within a div called "Linear". I also have a group of elements that are within a div call "wheels". There is a symbol off of the main stage called cycle_linear which alternately hides or shows the Linear div or wheels div. This ends up hiding or showing all of the many elements within each div. It works great within the browser. The problem that I'm having is when I click on the group div called "Linear" in the elements panel OR if I click on any of the elements within this group on the edge main stage it MAKES EDGE HANG .

           

          I think I know why, but I'm hoping I'm wrong and that there is actually a fix for this. The problem does not happen with any of the other div groups I have, but there is not nearly as much info contained within those groups. The "Linear" group has many very long, narrow, vertically scrolling textboxes and rectangles. Many are in the neighborhood of 10000 pixels long, which seems to be a built in limit within edge for a vertical dimention. There is probably close to or over 100 of these long, narrow, vertically scrolling elements within this div group.

           

          I imagine that when I click on this group edge is somehow trying to DO SOMETHING with all this info at once, and simply can not handle it. Sometimes it will come out of this hang after a few minutes, but most times I end up having to close and restart. I have worked around this by clicking only on the individual elements within the element panel (NOT the main stage), and I can edit each one just fine. I am able to click the twirl down and twirl up triangles beside the div group in the element panel without making edge hang .

           

          Perhaps if edge could use multiple processors at once the program could better deal with the overload. I could understand it hanging if I was actually trying to move the entire div group or do some other changes, but just clicking on it causes this problem.

           

          Any suggestions from the experts would be great. I know this file is quite complicated, but I'm not nearly done. I'm hoping edge will be able to handle what I want to add in the future.

           

          If i had to do this again I would probably have made the "Linear" div group it's own symbol or even a group of nested symbols, but I don't know how to reverse engineer that without having to rewrite everthing over. Copying and pasting elements from one location to another seems to mess up the x y coordinates.