3 Replies Latest reply: Feb 2, 2013 11:19 AM by Jeff A Wright RSS

    Minimum system requirements not met


      I just purchased Photoshop Elements 11, but realized too late that my Mac doesn't meet the minimum system requirements for installation. I have a Mac OS X 10.5.8, but require 10.6. How can I exchange Elements 11 for Elements 10, now that I've already paid?