2 Replies Latest reply on Feb 2, 2013 7:44 PM by d.duffee1962

    Where are the extensions for versions older than CS6?

    d.duffee1962

      When I go to the Adobe Exchange at https://www.adobeexchange.com/, the only clickable option I see is to download Adobe Exchange panel for CS6. Since I'm running CS5.5 for Mac, this won't install. There's no search feature. When I go to http://www.adobe.com/ and do a search for Adobe Extensions for CS5.5 for Mac, I get taken to links that ultimately all point back to https://www.adobeexchange.com/. I am caught in an endless loop. Why is this so difficult now? It used to be so easy!